1

I have gone through number of blogs and have seen the below steps to restore the new option.

  1. Type regedit in RUN dialog box and press Enter. Now go to following key:

    HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\

  2. Now create a new key "New" under "ContextMenuHandlers" key.

  3. Select "New" key and in right-side pane, set the value of Default to:

    {D969A300-E7FF-11d0-A93B-00A0C90F2719}

  4. Close Registry Editor and you'll get the missing "New" option back in context menu.

However I do not have the same structure. Currently the structure in my PC is -

HKEY_CLASSES_ROOT\Directory\DefaultIcon HKEY_CLASSES_ROOT\Directory\shell HKEY_CLASSES_ROOT\Directory\shellex

I have applied the changes under HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\New. It does not resolve the issue. Please help me to fix the issue.

1

If the following branch does not exist, you need to create it.

HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers

Alternately, use the following REG file to create the key and the (default) value data automatically.

Copy the following lines to Notepad, and save the file with .REG extension ("new.reg"). Double-click the file to apply the settings to the registry.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New]
@="{D969A300-E7FF-11d0-A93B-00A0C90F2719}"
  • I will try this out. Do I need to remove the new key which I have added under - HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\New – Arnab Oct 8 '17 at 9:46
  • Yes. That key can be removed. – Win32Guy Oct 8 '17 at 9:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.