1

I'm trying to use my laptop as a USB Receiver for a VM on my server. I have found a few USB Sharing programs, VirtualHere USB looked the most promising, but it seems my Xbox 360 Wireless Receiver and/or Gamepad don't show up as USB Devices and can't be shared. I also tried sharing over RDP, but I guess they aren't PnP devices.

Any suggestions? I will/would also like to share BT Wiimotes over the Network if you have any ideas, but that might be a separate question also might not be possible, I didn't see many results in google.

Goal: Plug in Xbox 360 Wireless Receiver and connect Xbox 360 Controller to laptop, which passes input to a VM over some form of connection, be it RDP, TeamViewer, non desktop sharing software etc.

  • Update: I'm fairly certain I got VirtualHere USB Server to work for this purpose and it was free for 1 device at a time. – FreeSoftwareServers Oct 9 '18 at 1:27
2

So I was already trying to do this, but apparently its much more difficult in Windows 10 (Got to love "updates")...

Anyway, what I ended up using since its free (There are probably better alternatives that are paid like Flixehub) is using RemoteFX USB Redirection over Windows RDP.

To enable in windows 10:

Do on both Physical Windows Machine and Remote Host

All Edits are under the following:

Computer Configuration \ Administrative Templates \ Windows Components \ Remote Desktop Services \ >>

GPEdits:

Remote Desktop Connection Client \ RemoteFX USB Device Redirection \ All RDP Redirection (Enable)

Remote Desktop Session Host \ Remote Session Environment \ RemoteFX for Windows Server 2008 R2 \ Configure RemoteFX (Enable)

Remote Desktop Session Host \ Connections \ Allow users to connect remotely using Remote Desktop Services (Enable)

Remote Desktop Session Host \ Device and Resource Redirection\ Do not allow supported Plug and Play device redirection (Disable) 

gpupdate /force in elevated CMD Prompt and reboot

Source: >> https://stackoverflow.com/questions/33719489/how-to-enable-usb-redirection-in-windows-10/46628854#46628854

Note: This also enabled me to share my BT, but I didn't test it yet

Using the Feautre in RDP:

Open RDP >> Show Options >> Local Resources >> More >> Other Supported RemoteFX USB Devices >> (Enable Device to share)

enter image description here

Then Connect and go under "Devices and Printers", it should be listed, perhaps have to install drivers.

  • While this works for sharing Gamepad over LAN, turns out RDP won't let me launch DirectX Games :'(, so I am doing RetroArch + Ice + Steamlink since my gateway is by the TV in the other room. freesoftwareservers.com/wiki/… – FreeSoftwareServers Oct 9 '17 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.