3

I was trying to remove Clementine but the problem is that the apt thinks sees that some packages require packages that the dpkg won't execute because of a conflict. I tried with apt --fix-broken install but it doesn't work. Can you help me?

This is what I got:

apt --fix-broken install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: casefile clamz fonts-roboto fonts-roboto-hinted jsql kio-audiocd libass5 libavformat56 libblas-common libbluray1 libcamel-1.2-59 libcoin80v5
libcrossguid0v4 libdap23 libebook-1.2-16 libebur128-1 libemu2
libevent-core-2.0-5 libevent-openssl-2.0-5 libevent-pthreads-2.0-5
libgfortran3 libgif4 libgmime-2.6-0 libgnome-autoar-common
libgraphicsmagick-q16-3 libgtop-2.0-10 libhunspell-1.4-0 libjasper1
libjim0.76 libjs-iscroll libjs-mochikit libkcddb4 libkcompactdisc4
libloudmouth1-0 liblouis12 liblua5.1-0 libluajit-5.1-2 libluajit-5.1-common libmicrohttpd10 libmysqlclient18 libnepomukcore4 libntfs-3g871 libobs0 libopenscenegraph100v5 libopenthreads20 libpango1.0-0 libpangox-1.0-0 libpcre16-3 libpcrecpp0 libperl5.24 libpoppler64 libqgis-core2.14.11
libqgis-gui2.14.11 libqgis-networkanalysis2.14.11 libqgispython2.14.11 libqgsttools-p1 libqt5multimedia5-plugins libqt5multimediawidgets5
libqtscript4-core libqtscript4-gui libqtscript4-network libqtscript4-sql libqtscript4-uitools libqtscript4-xml libradare2-1.1 libtag-extras1 libtinyxml2.6.2 libtracker-control-1.0-0 libtracker-miner-1.0-0
libtracker-sparql-1.0-0 liburcu4 libwebpmux2 libwireshark8 libwiretap6 libwsutil7 libx265-95 libxine2 libxine2-bin libxine2-doc libxine2-ffmpeg libxine2-misc-plugins libxine2-plugins maltegoce nepomuk-core-data obs-plugins python-advancedhttpserver python-alembic python-boltons python-cheetah python-dap python-editor python-formencode python-geoip2 python-geojson python-icalendar python-maxminddb python-mpltoolkits.basemap
python-openid python-pampy python-paste python-pastedeploy
python-pastedeploy-tpl python-pastescript python-pluginbase python-pylibemu python-pyotp python-scgi python-smoke-zephyr python-tempita python-tzlocal python-unicorn rename Use 'apt autoremove' to remove them. The following additional packages will be installed: libsidplay1 libtag1c2a Suggested packages: sidplay-base xsidplay The following NEW packages will be installed: libsidplay1 libtag1c2a 0 upgraded, 2 newly installed, 0 to remove and 1 not upgraded. 23 not fully installed or removed. Need to get 0 B/84.7 kB of archives. After this operation, 304 kB of additional disk space will be used. Do you want to continue? [Y/n] y dpkg: regarding .../libtag1c2a_1.9.1-2.1_amd64.deb containing libtag1c2a:amd64: libtag1v5:amd64 conflicts with libtag1c2a libtag1c2a:amd64 (version 1.9.1-2.1) is to be installed.

dpkg: error processing archive /var/cache/apt/archives/libtag1c2a_1.9.1-2.1_amd64.deb (--unpack): conflicting packages - not installing libtag1c2a:amd64 dpkg: regarding .../libsidplay1_1.36.59-6_amd64.deb containing libsidplay1: libsidplay1v5 conflicts with libsidplay1 libsidplay1 (version 1.36.59-6) is to be installed.

dpkg: error processing archive /var/cache/apt/archives/libsidplay1_1.36.59-6_amd64.deb (--unpack): conflicting packages - not installing libsidplay1 Errors were encountered while processing: /var/cache/apt/archives/libtag1c2a_1.9.1-2.1_amd64.deb /var/cache/apt/archives/libsidplay1_1.36.59-6_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

  • 1
    Did you ever mix other repositories than official Debian? That's the usual cause for this when newer packages than available conflict and won't be replaced. You can try to force Debian stable to install over other (newer) versions by temporarily pinning stable preferences to >= 1001 (instead of default 500) in apt pinning (man apt_preferences or see wiki.debian.org/AptPreferences). Check also the output of apt-cache policy or apt-cache policy packagegivingtrouble. Also having 23 packets half installed isn't helping (and requires this --fix-broken for apt to even want to work) – A.B Oct 8 '17 at 15:22
  • Please add the output of cat /etc/apt/sources.list and cat /etc/apt/sources.list.d/* – GAD3R Oct 9 '17 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.