10

I have two user accounts on my Linux Mint KDE 18.2 machine:

  • One is me (say chitholian) as a sudo-privileged user with SHELL=/bin/bash.
  • Another user (say csecu) without sudo having SHELL=/bin/ftponly (a custom shell that actually does nothing).

I created the second account so that my classmates can have access via FTP for file sharing, but I don't want to allow them to login via ssh or anything else except FTP.

My problem is when I boot up, the login window shows both accounts, even after I have changed the shell of that second user to disable his shell activity.

I want to hide that user account from the login dialog too. How should I go about achieving this goal?

1
  • According to the sddm.conf manual, SDDM by default hides users with user IDs lower than 1000 or higher than 60513. So one way to achieve what you need might be to change the user ID of the affected user. Nov 15, 2023 at 21:25

1 Answer 1

11

Edit /etc/sddm.conf. Under [Users] you find a setting called HideUsers=. Just add the user there. Since the user you want to hide uses another shell you could also use the setting HideShells in the same section.

2
  • 2
    then you can test if it worked with sddm-greeter --test-mode
    – AmanicA
    Aug 5, 2023 at 17:26
  • 1
    According to the manual of sddm.conf.5, the system configuration directory is /usr/lib/sddm/sddm.conf.d and the local configuration should be created in /etc/sddm.conf.d directory. It might be missing on systems which do not use any configuration overrides. Nov 15, 2023 at 21:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .