So I've been using an SD card in my RPi (Samsung EVO 16GB SDHC). I've formatted and re-written this card many times a while ago, but hadn't touched it recently. When I tried to do so this time, the disk showed up as 4 different disks on my laptop. After doing some research, I found out that these were the 4 partitions on the disc, created by Linux. I tried many approaches to clean the disk:

  • Diskpart
  • Removing partitions in Disk Manager
  • SD Card Formatter
  • Bootice
  • win32DiskImager

None of these had any effect. Partitions simply will not delete, even though several operations say "successfully removed". Now normally I'd say this card is a write-off, but when I plug it in to my RPi, it still works just fine.

Is there anything I'm missing here, or is my SD card simply stuck in its current state, and thus a write-off?

  • 1
  • 1
    Aside from dd, GParted (use live bootable image) might be worth a try.
    – andselisk
    Oct 9, 2017 at 11:36
  • @andselisk So you can do that from the RPi while it's running? Since the Sd card is the only storage it has, I assumed it would crash if I'd do that. I did try using GParted, but couldn't get it to work (was tired and frustrated). Might give it a try later.
    – Timmiej93
    Oct 9, 2017 at 11:41
  • No, you cannot, if you are booted from this very MicroSD. Did you run win32DiskImager from RPi too? I guess no, so I assume you have a separate computer where you can boot to any Linux distro and use either dd or GParted.
    – andselisk
    Oct 9, 2017 at 11:45
  • I ran everything from my Win10 machine, with the sd card in an integrated card slot (with adapter). Can these actions be done from the 'Bash on Ubuntu on Windows' program that comes with Win10?
    – Timmiej93
    Oct 9, 2017 at 11:47