1

I tried to make myself a German QWERTY layout by just switching the z and y key on my keyboard and creating a fitting layout with the Microsoft Keyboard Layout creator since there is no native support.

That works just fine for text input, but not in any other context. Shortcuts like Ctrl-Z and Ctrl-Y are now flipped since the layout apparently doesn't apply to them. I can input text correctly in the same application, but keyboard shortcuts seem to get treated differently. same goes for games, there's a bunch of them that use ZXCV as unrebindable substitutes for the ABXY keys on a controller. Just imagine using YXCV with a QWERTY layout, it's not very fun.

I thought the reason for this was that the applications use some kind of direct input from the keyboard that doesn't even go through windows, but that can't be the case since I can use the standard US QWERTY layout with no complications regarding the z and y key.

Is it just impossible to create a layout for Win 10 in MSKLC that works properly or am I missing something? I found lots of topics on getting MSKLC to run it all on Windows 10, but none on this specific issue.

1

Turns out it had something to do with my windows language settings. It was set to "English (en-DE)" instead of "English (United States)". The language itself seems to be another modification layer applied to the keyboard layout contained within. Make sure you also set the language in the MSKLC project properties to US English, not German.

  • Still not correct. I have created MSKLC layout for Hindi language (hi-in) and I can use it everywhere, had not found a single place where it is not working in 15 years or so. MSKLC comes to effect only when you change keyboard by default Alt-Shift, then the language changes and the char set changes that keyboard produces. so, MSKLC is based on language itself, other than that there is no limitation of MSKLC vis a vis any particular language. You should try to find more reasons for the problems you are facing. – VSRawat Feb 6 at 21:19
0

You must change the VK code as well. This happend to me, too, when I changed my keyboard layout. You can edit the .klc file directly with a text editor, and recompile it, swapping the VK_Y with VK_Z.

See my answer here. I was inspired by this answer.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.