I'm having an issue with my computer; I recently installed Deepin Linux, based on Debian, and I'd like to use my internal ntfs formatted HDD on it.

I made an fstab entry to auto-mount it at startup, here is the line:

UUID=BE9823F89823AE39 /media/Data ntfs defaults,gid=1000,uid=1000 0 0

The problem is that in the defaults options, the disk is supposed to be mounted as rw, but it's still in read only mode.

Does anyone has an idea to help me?

I did what jpgaugh said, but it still doesn't work; here is my new fstab line:

UUID=BE9823F89823AE39 /media/Data ntfs-3g defaults,gid=1000,uid=1000,dmask=022,fmask=133 0 0
  • 1
    Use ntfs-3g. Write support to NTFS is considered unsafe by the kernel team, and thus is not included by default. You should back-up your NTFS partition before attempting to write to it. However, I've never had any issues in practice; but since NTFTS is closed-source, there's no guarantee that their won't be issues, either.
    – jpaugh
    Oct 9, 2017 at 21:00
  • Welcome to Super User! I can't remember the specifics, but if the link I mentioned above helps, go ahead and provide your solution as an answer here. That will allow you to find it a year from now when you forget, and possibly help others as well.
    – jpaugh
    Oct 9, 2017 at 21:23
  • I dit what jpgaugh said, but it still doesn't works; here is my fstab line : UUID=BE9823F89823AE39 /media/Data ntfs-3g defaults,gid=1000,uid=1000,dmask=022,fmask=133 0 0
    – BDeliers
    Oct 10, 2017 at 5:59

2 Answers 2


Okay, I finally found how to make it work.

The problem was because of Windows 10, which left some Windows cache data on the partition. To solve it, I booted on windows, I disabled the fast start option and I restarted to Linux, and now it's okay.

Here is my working fstab line:

UUID=BE9823F89823AE39 /media/Data ntfs-3g defaults,gid=1000,uid=1000,dmask=022,fmask=133 0 0 
  • Ah, okay. Yeah, the NTFS tools on Linux are really conservative. If there the dirty bit is set, for example, you have to run chkdisk on Windows before you can use the partition.
    – jpaugh
    Oct 10, 2017 at 19:01

Also know that with windows 10 you have to be careful because the default shutdown puts the ntfs disks to sleep or hibernation rather than the traditional state of being flushed & unmounted or whatever it's called; this will either cause problems for other operating systems mounting that ntfs disk or when windows 10 goes to access it again after someone else has accessed it when it was hibernated by win10, then win10 will often think it is dirty and do a disk check.

Windows 10 - control panel - power options - System Settings or Choose what the Power Buttons do - uncheck Turn on fast startup (recommended)

turn off fast startup

for a better technical answer of what is happening, a web search on windows 10 disk fast startup would explain. I had numerous windows 10 problems and linux mount problems going back & forth with win10 on one disk and linux on another disk where linux uses ntfs-3g to access my ntfs disks. Also, they say the win10 fast startup does not affect restart it only affects shutdown

and from tuxera.com the deloperers of ntfg-3g they state:

Windows hibernation and fast restarting

On computers which can be dual-booted into Windows or Linux, Windows has    to be fully shut down before booting into Linux.
otherwise the NTFS file systems on internal disks may be left in an inconsistent state and changes made by Linux may be ignored by Windows.

So, Windows may not be left in hibernation when starting Linux, in order to avoid inconsistencies.
Moreover, the fast restart feature available on recent Windows systems has to be disabled.
This can be achieved by issuing as an Administrator the Windows command which disables both hibernation and fast restarting :

powercfg /h off

Not the answer you're looking for? Browse other questions tagged or ask your own question.