1

What I did:

  1. Activated Hyper-V (Enable Virtualisation / Enable Hyper-V Feature ect.)
  2. Downloaded the Fedora iso 64bit
  3. Created Hyper-V VM and Installed Fedora
  4. Created a Virtual Switch for my VM
  5. Decided Hyper-V is total bullocks, decided to opt for a different VM Manager
  6. Removed my VM
  7. Deactivated Hyper-V
  8. Uninstalled the Hyper-V Switch Via Device Manager
  9. Restarted PC
  10. Lost Connectivity via my one network adaptor (my motherboard has 2).

Here's the funny bit. I'm running dual boot Ubuntu. When I try to use my 2nd network adaptor in Ubuntu it doesn't work. insert mind blown gif

Did Windows f#!k with my Firmware? Did I just lose my 6GB network card because some intern at Microsoft f#!ked up?

Link to Motherboard's Page

  • 1
    You have to remove HyperV switch from HyperV management console, not from device manager. – Biswapriyo Oct 11 '17 at 4:36
  • Yeah I realised that's where I went wrong. It's stupid that they alter the firmware though to allow for that passthrough – Zander Rootman Oct 11 '17 at 22:13
1

Okay so it sprung back to life. I'm not going to mark this answer as correct, since I'm not ENTIRELY sure what I did that fixed it. I did so many things... So.. So many things.

  1. Re-Enable Hyper-V (Virtualization / Feature Activation)
  2. Create Virtual Switch (While being plugged in to your network adapter that ISN'T working)
  3. Remove Virtual Switch (While being plugged in to your network adapter that ISN'T working)
  4. De-Activate Hyper-V on Feature List
  5. Wait for restart loop to finish
  6. Go into BIOS De-activate virtualization
  7. If your BIOS has the option, install LAN Drivers via your BIOS

Conclusion:

My implementation of Hyper-V was probably incorrect (unrelated). I'm not saying Hyper-V is stupid, I'm saying the way Windows handles it's network interfaces is. Somewhere along the lines I think Windows tried some sort of Firmware hack to bridge connection between my Network Adapter and Virtual Switch and me removing things "incorrectly" did something strange to it.

Advice for the Lost Soul

If you're not a masochist like myself and you don't thoroughly enjoy banging your head against a sour stone wall, see if you can't re-flash the firmware of your network adapter you're trying to recover.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.