1

This is a really bugging one: I am writing a document in Dutch language, and from the moment I start typing, the proofing language changes into English, mentioning that I am writing nothing but errors.

As mentioned on Office support, I have set the proofing language as "Dutch (Belgium)", but this does not solve my issue. In the Language preference, I have removed "English (Belgium)" from the list (English is not a Belgian language, so how can you have an "English (Belgium)" proofing), but after having restarted MS Word, the "English (Belgium)" just reappears in the Language preference and when starting typing, the proofing language changes immediately to "English (Belgium)".

Sorry for sounding so frustrated (but I really am), does anybody know how I can get rid of a proofing language so that it never appears again? (I've just checked "Add and Remove Programs" and I don't find any language references)

I'm working with Microsoft Word 2016 MSO 32-bit.

  • What are your system locales? Word follows Windows so removing (or adding) a language from the language preference in office may not work properly when the languages list is not consistent with Windows' – Sanny Oct 18 '17 at 14:31
  • My system language is English(United States). – Dominique Oct 18 '17 at 14:35
  • Are Dutch and English (Belgium) listed in the input languages in Windows as well? – Sanny Oct 18 '17 at 14:45
1

You have to change your "default input language" to the language you want Office to spell check as default. (Win7: Start > Control Panel > Change keyboards or other input methods > Change keyboards... > Select language in dropdown menu.)

I am aware that this is not a real solution to your answer but apparently there is no good fix. This is a bug in Office which is described here: https://support.microsoft.com/en-us/help/292106/changes-to-default-language-settings-are-not-retained-in-word

| improve this answer | |
0

Start> MS Office 2016> Office 2016 Language Preferences. You use top part to set your default editing language (click Dutch and click 'set as Default' button). For existing documents you have to change the language like this: Open document, Ctrl+A to select all content, click language down left at the status bar, click your language and OK. Save.
It's truth it doesn't exactly answer your question as is but it should fix your issue. As for removing existing proofing language, I believe you can't remove the language in which you have Office installed, but that's just my theory, I cannot test it.

| improve this answer | |
  • Those are all the steps I have already performed before. I did them again but the problem is still there. – Dominique Oct 12 '17 at 12:46
  • That's very interesting, I just tested it and I can confirm this incorrect behavior even in 1708 version. Even direct editing of normal template didn't change default language..Could we be hitting a current branch bug..? I'm going to do a few more tests. – Ren Oct 12 '17 at 13:06
  • For your information, I'm also running version 1708, more exactly build 8431.2107 Click-to-run. – Dominique Oct 12 '17 at 13:21
  • OK, I have no other explanation than this is a bug. Changing default language DOES create a new normal.dotm as expected, with new default language, for document and styles...Only issue is these settings are not honored when you start typing..:-/ I'll pass the info into Insider program, we'll see if it's gonna help. – Ren Oct 12 '17 at 18:43
  • Thanks (by the way, what is "Insider"? Is it some procedure to mention bugs to Microsoft?) – Dominique Oct 13 '17 at 7:01
0

I have encountered similar problems when typing beyond the end of the document. The language would change by itself to that of the operating system.

My solution in such cases is never to type at the end of the document. I always leave at least one empty line at the end and I place the cursor before it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.