6

All the methods I used to use, including my trusty .reg file

[HKEY_CLASSES_ROOT\InternetShortcut]
"EditFlags"=-
"IsShortcut"=-
"NeverShowExt"=-

I rebooted after applying it, but they still don't seem to show the .URL extension.

Any idea how to get that to show?

3
  • You should be able to use the same method you have always used.
    – Ramhound
    Oct 12, 2017 at 14:09
  • Is "hide extensions for known file types" checked off in folder options?
    – BrianC
    Oct 12, 2017 at 14:36
  • Nope. It's not enabled, the machine isn't domain joined (so no overriding policy) and it was rebooted multiple times since.
    – Trel
    Oct 12, 2017 at 15:45

2 Answers 2

5

I found what I needed to do, in addition to removing those entries from

HKEY_CLASSES_ROOT\InternetShortcut

I ALSO had to remove them from

HKEY_CLASSES_ROOT\IE.AssocFile.URL

Removing it from both, then rebooting, now shows the .URL extension and allows editing.

2

So even if show file extensions is set, there are still some super hidden extensions. See here

The solution for ".url" extension: create a file named "show_url_extension.reg" with the following contents:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\InternetShortcut]
"NeverShowExt"=-

[HKEY_CLASSES_ROOT\IE.AssocFile.URL]
"NeverShowExt"=-

After apply, need reboot to take effect

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .