12

When I create a new folder on the desktop and give it a name, the new name does not take effect until I manually refresh the desktop. The same thing happens when I try to delete it.

This behavior also applies to new .txt files, Word documents, Excel spreadsheets, etc.

Here is a GIF of it happening to a folder:

  • Tips:: Take ownership of C:\users\username\Desktop folder. Or delete desktop.ini file in Desktop folder. Or clean file history & file icon cache. – Biswapriyo Oct 12 '17 at 20:29
  • Took ownership and deleted the desktop.ini file but neither worked and file history is off: i.imgur.com/ZBAlacQ.png. Let me look at doing file icon cache and I'll let you know. – super.challenged.user Oct 13 '17 at 16:38
  • add these comments in your answer to show what you've tried to solve. – Biswapriyo Oct 13 '17 at 17:44
  • Does this happen if you perform a Clean Boot of Windows? – I say Reinstate Monica Oct 31 '17 at 3:13
  • Did you ever solve this? Been happening to me for six months, all folders not just desktop. None of the answers made a jot of difference. Clean install of Windows 10 running on a VM on MacOS. – Ben McIntyre Mar 3 '19 at 2:40
3

Try this:

Settings > Personalization > Themes > Change desktop icons > Restore default

If it cannot solve your issue, please also try to reset folder views:

Screenshot

Also go to HKCR\CLSID\{BDEADE7F-C265-11D0-BCED-00A0C90AB50F}\Instance and change DWORD value DontRefresh from 1 (on) to 0 (off).

| improve this answer | |
  • So I tried both of your suggestions but it's still not working. Reset Folders: i.imgur.com/BwUC2Rx.gif Registry Edits: i.imgur.com/toLTS2L.mp4 The key you posted does not exist on my system. I added it myself per the advice of this article here: i.imgur.com/241Wmr4.png Also based on the article the key you posted is for 32-bit systems whereas 64-bit systems is stored under HKCR\Wow6432Node\CLSID\. Not that it matters since neither one works. In case you're wondering I made sure to reboot my system before taking the video after I made those changes. No dice. – super.challenged.user Oct 13 '17 at 16:26
  • check your C drive policy: 1drv.ms/i/s!Avq27-O7I1GRgxHOqT_MXF92RR2A then run ShellExView software, in the pane sort the entries with manufacturers. Disable all non-Microsoft *.dll files, and check the result. If the issue does not occur, one of the files can be the culprit. We could narrow down it one by one. – Waka Oct 16 '17 at 2:14
2

Haven't tried this solution for your specific problem, but I'd consider it worth trying if I came up against your set of symptoms:

Save the following as a .bat file:

ie4uinit.exe -show
taskkill /F /IM explorer.exe
cd /d "%userprofile%\AppData\Local\Microsoft\Windows\Explorer"
attrib -h iconcache_*.db
DEL /A /Q "%localappdata%\IconCache.db"
DEL /A /F /Q "%localappdata%\Microsoft\Windows\Explorer\iconcache*"
start explorer

Save and close all files and programs, then run (it doesn't require admin).

When it completes restart your computer.

This script is for resetting desktop icon issues in Windows 10. Any shortcuts on your desktop should return to a default position to the upper-left of the primary screen.

| improve this answer | |
1

I had a samba share to a network printer scan folder pinned in the quick access folder. After trying all other solutions including resetting my Windows, this worked! Look to see if you have any shortcuts to poor performing network locations.

| improve this answer | |
  • This is a comment, not an answer – JW0914 May 7 at 11:44
1
  1. Settings > Personalization > Themes > Change desktop icons > Restore default
  2. Uncheck Allow themes to change desktop icons > Apply > OK

If this does not work:

  1. Restore default > check Allow again > Apply > OK
  2. Go back in and Restore default > uncheck Allow again > Apply > OK

Unsure why I had to do this more than once, but it works now.

| improve this answer | |
0

the same problem happened with my laptops desktop I also run Windows 10, the only thing I had to do was powering my laptop off and then on again, and then it refreshed When Moving/Renaming/Deleting Files & Folders. I hope it helps you too.

| improve this answer | |
  • Sorry, for giving my answer so late, this happened to me recently and just wanted to share what happened with me, and hope it help anyone in the future if they have similar problems – Neji Jul 2 '18 at 18:56
0
  1. Go to Folder Options
  2. Untick the two Quick Access options within the General tab under Privacy
  3. Click Clear File Explorer History
| improve this answer | |
0

It took me forever to find out the fix to this issue, and I was tempted to just reset my whole PC, with the only thing stopping me being a slow connection. Thank you, Joan, for your answer which give me an idea of how to fix it.


Here's how I finally got it:

After I went to Settings > Personalization > Themes > Desktop Icon Settings, I received a message saying something like You do not have the permission to access this file and rundll32.exe was listed in the top bar.

I went to C:\Windows\System32\rundll32.exe and followed this procedure:

  • Right-click rundll32.exe > select Properties > Security tab > Advanced.
  • Click "Change", beside the "Owner" line of text, and change this to your user name.
  • To close all the security and properties tabs: Apply > Accept everything > OK
  • Right-click rundll32.exe > Properties > Security > Advanced > Enable inheritance
  • Apply > accept everything > OK
  • Once out of the Security and Properties tabs, close Explorer window > Restart PC

Upon restart, your auto-update should be working again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.