0

So, I'm having this ridiculously weird problem. Context menus and modal dialogs exists, but are not shown. The problem is for one single application, called Visual Nand Reconstructor.

See this screenshot, taken from within Windows 7:

enter image description here

The dialog can be clearly seen in the screenshot (in MS Paint). But when returning to the application, the dialog is /not/ seen at all. The GUI is stuck, until I click "yes" or "no". Which I cannot, with the mouse, but pressing space activates "yes", the dialog disappears, and the GUI is responsive again.

Here's a screenshot for the exact same situation, but from a Teamviewer host instead:

enter image description here

Same situation, but the dialog is not seen.

The same goes for context menus. Right-clicking objects open an invisible context menu; I can select items with the keyboard, but I have no idea what I'm selecting.

The only workaround for this problem is taking a screenshot everytime the GUI locks up, watching in MS Paint whatever dialog has popped up, and go from there.

Incredibly frustrating, as I have no idea what's causing this. The application worked when I installed it the first time a week ago, but the behaviour started during the weekend. No new applications / updates / whatever were installed during that time, and right now I've installed all available updates, including the GPU-driver, rebooted numerous times, but the problem persists.

Does anyone have a clue what's going on? I seldom use .NET programs so I'm unaware if it's local to this program, or for all .NET:s.

  • 1
    So this only happens when you use TeamViewer? – Ramhound Oct 13 '17 at 23:24
  • Well, I'll be damned. You're right. I went to the workshop, sat physically at the computer in question, and all worked flawlessly. Teamviewer is the culprit. But why? – bos Oct 14 '17 at 8:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.