1

I've just come across this question which outlined the process of starting an application on a specific virtual desktop. The only issue is, Discord uses a different method of starting, which looks like this: (copied from the Start Menu shortcut)

C:\Users\<username>\AppData\Local\Discord\Update.exe --processStart Discord.exe

When I add the VDesk command into the mix like this:

vdesk on:2 noswitch:true run:"C:\Users\<username>\AppData\Local\Discord\Update.exe" --processStart Discord.exe

Discord opens up the exact same way as if it was launched normally, on the current active virtual desktop. This vdesk command only works if I edit the shortcut, because the "Start in" directory determines what version of the application is actually run, which is currently set to this:

C:\Users\<username>\AppData\Local\Discord\app-0.0.298

I've tried changing the shortcut to this:

C:\Users\<username>\AppData\Local\Discord\Update.exe --processStart "vdesk on:2 noswitch:true run:Discord.exe"

and also tried with the full path to VDesk:

C:\Users\<username>\AppData\Local\Discord\Update.exe --processStart "C:\Program Files (x86)\VDesk\VDesk.exe on:2 noswitch:true run:Discord.exe"

but these last 2 didn't even start the application at all. Running another application (HexChat) that uses a single exe file to start works without issues.

Is there a way to make this work?

  • Well, did you try to either start Discord.exe directly or change the brackets to actually include the parameters to the Update.exe? – Seth Oct 14 '17 at 13:06
  • @Seth I left the Update.exe in because I imagine I'd lose startup updates of the app. I don't know what brackets you're referring to. – SeinopSys Oct 14 '17 at 13:14
  • Sorry, not brackets but quotes. In your second example (vdesk o ...) you'd (probably) only start the Update.exe on that display. – Seth Oct 14 '17 at 13:15
  • 1
    @Seth According to the latest VDesk readme arguments are added after the command. If I include the arguments in the run:"..." part I get a message saying "The system cannot find the path specified" – SeinopSys Oct 14 '17 at 13:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.