Recently, I could not boot my MacBook because it lacked enough free space. I booted into single user mode and freed up about 85GB. After doing so, it booted fine and I have been using it with no issues since, until… today when I tried to restart, I experienced the same issue. The Apple logo appears and the white progress bar gets about 90% of the way and then it shuts down.

Here’s what I’ve tried so far:

  • Reset NVRAM with Option+Cmd+P+R
  • Booted into recovery mode and attempted to run disk repair which failed with exit code 8.
  • Booted into single user mode and ran fsck-fy which returned an error: “Invalid node structure; Invalid sibling link; Rebuilding catalog B-tree. Disk full error”

The df command shows that the drive is at 64% capacity, which to me means I should have plenty of free space.

Any suggestions as to what I could try next? I’m not super savvy with issues like these, just good at Googling, so I’m wondering if I should just give in and take it somewhere as I don’t want to make things worse if it’s actually recoverable.

Output of df and df -i:

Output of <code>df</code> and <code>df -i</code>

  • I don't know about Mac but in Linux df -i will show you inode information. When you run out of inodes (i.e. df -i shows 100% usage), filesystem reports it's full, even if it has empty blocks still available (plain df reports moderate usage). I'm not sure it can cause errors you reported, still it's worth to check it out. Plenty of small files will consume plenty of inodes and relatively little space. Something may generate these files like crazy but for now it's impossible to say what it may be. If you're not sure then edit your question and add the relevant output of df and df -i. Oct 14, 2017 at 20:54
  • Thanks! I’ve edited and added the output. To me, if I’m understanding the output correctly, then it’s showing plenty of free inodes, right?
    – Lauren
    Oct 14, 2017 at 21:19
  • Both outputs contain inode information. Yes, there are plenty of them free on root_device. At the moment I cannot help you further, I have no experience with Macs. Oct 14, 2017 at 21:26
  • What model MacBook are you using? Oct 15, 2017 at 18:55

1 Answer 1


Your fsck returned volume structure errors that disk utility can't repair.

You can use a utility like DiskWarrior to repair the directory structure.

Otherwise, an easier (but longer) method is to backup, erase the partition then restore the backup (the erase will setup a new file system with no damage). This works best via cloning the files (not the partition itself, that would preserve the issue) while booted from another operating system.

Another erase method would be to backup with time machine, boot to the Recovery disk (command-R during boot) and use disk utility to erase the partition. Use the installer to reinstall your OS then when it prompts you to restore a backup afterwards restore the time machine backup.

  • 1
    Thank you. I was holding out hope for a quick fix. But, after spending an entire day on it, I got impatient and ended up doing what you suggested---erasing the drive, which of course worked.
    – Lauren
    Oct 16, 2017 at 17:03
  • can I repair the disk using a linux box?
    – Ahmed Eid
    May 10, 2019 at 0:14
  • I haven't tried it but hfsutils does have an hfsck binary and hfsprogs has fsck.hfsplus but I haven't used either one. If I end up having filesystem issues from any HFS device I've always used macOS based utilities to address it. But if you could make an image of the drive you could try to use one of the aforementioned binaries to try and repair the IMAGE (not the original disk, at least not until you've had success on the disk image since it's expendable).
    – Cory T
    May 10, 2019 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.