4

I'm using iTerm2 on my Mac, build 3.1.3, and I am working with two tabs. One tab has my Python code in vim. The other one is where I actually run it with python code_here.py.

However, each time I edit in vim, save, and then switch tabs and run the same python code_name.py command, I constantly get this popup message:

Session IPython: Users/myname/ (vim) #1 just rang a bell!

How do I completely disable this popup? Actually, for that matter, I'd like to disable all such popup message from iTerm2.

  • 1
    Preferences -> Profiles -> Terminal tab -> Check "Silence bell" ? – DavidPostill Oct 15 '17 at 17:54
  • 2
    Preferences -> Profiles -> Terminal tab -> Uncheck "Send Growl/Notification Center Alerts?" – DavidPostill Oct 15 '17 at 17:57
  • 1
    Both of ^^^ are significantly more helpful to me personally than the accepted answer. – cbmanica Jul 14 '20 at 22:04
4
  1. Apple System Preferences -> Notifications
  2. In the left list panel, scroll to find the entry for iTerm (or iTerm2).
  3. In the right control panel, set iTerm alert style to None.

Image: System notification settings for iTerm to disable vim notifications

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.