The dmesg output:

[ 9376.684650] mmc0: card 59b4 removed
[ 9378.738987] mmc0: cannot verify signal voltage switch
[ 9378.859232] mmc0: new ultra high speed SDR104 SDHC card at address 59b4

lsblk and fdisk -l does not show any new disks.
The KDE Partition Manager does not see it too.

I tried to find it in /dev but with no success:


Nothing of them is sdcard. The list is the same when SD card inserted and ejected.


lspci output (shortened):

$ lspci
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)

Unassigned class. Does this mean system needs driver for RTL8411B?

update 2. Solved semi-accidentally.

For a few hours I was digging the internet and found package which should install

A kernel module for Realtek Card Reader RTL8402/8411/8411B Device

It is named rts_bpp-dkms-git

~ ❯❯❯ yaourt rts_bpp-dkms-git
1 aur/rts_bpp-dkms-git 6-1 [installed: 7-1] (1) (0,00)
    A kernel module for Realtek Card Reader RTL8402/8411/8411B Device
==> Enter n° of packages to be installed (e.g., 1 2 3 or 1-3)
==> ---------------------------------------------------------

I tried to install it and met the yet another problem:

:: Running post-transaction hooks...
(1/1) Install DKMS modules
==> No kernel 4.9.52-lts headers. You must install them to use DKMS!

Seems package was installed but with FAIL. Need to install linux49-headers

$ pacman -Ss linux headers
# pacman -S linux49-headers

Note: use uname -a to get know the system name and Linux kernel version.

Than I have got one more thing about dkms cannot find linux headers fot 4.9.52. I checked pointed folder with

$ ls /usr/lib/modules/
4.9.53-1-MANJARO  extramodules-4.9-MANJARO

and found there linux headers version 4.9.53-1. I think that happened because of system was updated with octopi (pacman -Suy) and was not restarted.

O, Magic. After system reboot (sd card was inserted all time) Dolphin can see partiotons of SD card. And I have mmcblk0 device. Check it with lsblk.

  • 1
    For future reference, if lsblk does not find your disk, KDE Partition Manager would not find either. KPM uses lsblk --json to find the list of devices. – Andrius Štikonas Oct 16 '17 at 0:51

The problem: no driver for RTL8411B

$ lspci
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)

Solution find and install driver

But first we need to know: the drivers installed through dkms and it usually requires Linux headers.

First get know kernel version

$ uname -a  
Linux kyb-manjaro-laptop 4.9.53-1-MANJARO #1 SMP PREEMPT Thu Oct 5 15:11:15 UTC 2017 x86_64 GNU/Linux

It is 4.9.53-1-MANJARO

Second install Linux headers.

$ pacman -Ss linux headers

Select your one and install it

# pacman -S linux49-headers

Third install driver itself

$ yaourt -S rts_bpp-dkms-git

Last step - restart the system. Optional, may be your system will work without reboot.

P.S. To search drivers for another hardware chip try:

for Arch Linux based:


for Debian, Ubuntu:

apt search DRIVER_NAME
  • Thank you so much. I was longgg time figuring out why didn't work all the time under Manjaro. Now is working. – m3nda Oct 30 '18 at 20:48
  • 1
    Yo you totally saved hours of fighting with my computer. Thanks so much! – Mahkoe Mar 22 '19 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.