3

I am aware of similar questions to this one but none of them do solve my problem, My current operating system is fedora 26 minimal net-install with i3 windows manager, so it would be safe to assume that it is customly built Linux

➜  ~ lspci| grep VGA       
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
➜  ~ lspci| grep 3D 
0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)
➜  ~ uname -a
Linux localhost.localdomain 4.13.5-200.fc26.x86_64 #1 SMP Thu Oct 5 16:53:13 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

The problem is that I want to get Nvidia Card driver to work, At least be able to choose at booting time which one to use, and at best enable nvidia-prime to have dynamic switching between both graphic cards

I tried bumblebee, rpmfusion nvidia drivers, the official one provided by nvidia, and finally negativo repos for rpm nvidia drivers(current one), they all gave similar results. I already blacklisted nouveau driver (it doesn't show up in lspci) and tried to blacklist i915 driver so I would see if nvidia driver will work or not, but it didn't

This is the current Xorg Configurations

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "PrimaryGPU" "yes"
    Option "SLI" "Auto"
    Option "BaseMosaic" "on"
    ModulePath "/usr/lib64/nvidia/xorg"
EndSection

Section "OutputClass"
    Identifier "intel"
    MatchDriver "i915"
    Driver "modesetting"
EndSection
Section "Monitor"
    Identifier "Monitor0"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "intel"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor"
EndSection

when I change this line Driver "intel" to Driver "nvidia" then do startx I kind of hangs, it doesn't accept any input, ctrl+c doesn't kill get me back to tty shell, but "ctrl+alt+f2,f3" could move me to another tty when I move back to tty1 it doesn't display text there but rather screen freezes on whatever was already in the previous tty.

EDIT:

  • Note that the Section "OutputClass" is part of the driver installation, without the rest normally the screen goes totally black (as if it is off)

2 Answers 2

1

I think you are debugging at wrong level. Check whether X server work only answer your X server work or not. You can not check whether NVIDIA driver is successul loaded.

So you should start from checking whether nvidia is correctly installed and loaded. Boot into text console and run following command.

nvidia-smi

If it does not appear as belowed then your driver does not work

Thu Nov  9 13:12:09 2017       
 +-----------------------------------------------------------------------------+
| NVIDIA-SMI 384.90                 Driver Version: 384.90                    
|
|-------------------------------+----------------------+----------------------+

If your driver does work, use the below command to generate a new x-config

nvidia-xconfig

Then replace your old Xconf with new generated one. It does not work, then this is time to blacklist drivers, disable BIOS,....

0

I can't see your report, so i'll come up with a generic answer:

For normal cards and BIOS, this guide should solve your problem, thought I think you'll have already considered all this, but maybe you missed a dependency or some line in the config files. It uses an nVidia driver installer rather than installing them by hand. In the past I've allways done it by hand, but this may solve your strange problem.

If your system uses nVidia Optimus technology (which I believe it is the case) its a bit more tricky to get it to work on Linux, bumblebee (which you already tried) is usually the way to go. You have two chances:

  • Check Fedora Project Wiki Bumblebee page to see if you can make it work. You said you tried, but again, maybe you missed something.
  • The safest and fastest way to go is either dissable nVidia Optimus Technology or the Intel graphics card in your notebook's BIOS (banning the driver is not enough) and then try the standard nVidia driver installation procedure I refered earlier (or those tried by you in the past, except bumblebee). You will loose the dual graphic card function.

Please, dont downvote me because of the simplicity of my answer, I've not enough reputation to post this on comments yet, although this saved my live back in fedora 20-22 when I had a similar problem, so it should work.

2
  • Thank you for your reply, I have nVidia Optimus but no Bios Option for either disable either of the 2 cards or enabling or disabling optimus. regarding bumblebee, I was told on fedora official IRC channel that it is currently broken on fedora.
    – u185619
    Nov 8, 2017 at 17:35
  • I noticed that the link got expired but I am not able to reget the info currently, so I deleted the link, lesson learned.
    – u185619
    Nov 8, 2017 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.