I'm trying to solve some IT puzzles about crypto: http://overthewire.org/wargames/krypton/krypton0.html.

But I failed just with the very first exercise. I decoded the password with openssl (that was easy) but when I try to connect to the machine using ssh, it shows the below message: enter image description here

ssh: connect to host krypton.labs.overthewire.org port 2222: No route to host

I tried to ping the machine:

ping krypton.labs.overthewire.org
PING otw.cracksucht.de ( 56(84) bytes of data.
64 bytes from static. ( icmp_seq=1 ttl=53 time=54.5 ms
64 bytes from static. ( icmp_seq=2 ttl=53 time=54.0 ms
64 bytes from static. ( icmp_seq=3 ttl=53 time=54.6 ms
--- otw.cracksucht.de ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 54.054/54.411/54.626/0.254 ms

So it responds. I also tried to ssh to the machine using its IP:

dig krypton.labs.overthewire.org

; <<>> DiG 9.9.5-3ubuntu0.10-Ubuntu <<>> krypton.labs.overthewire.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38947
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;krypton.labs.overthewire.org.  IN      A

krypton.labs.overthewire.org. 119 IN    CNAME   leelo.overthewire.org.
leelo.overthewire.org.  119     IN      CNAME   otw.cracksucht.de.
otw.cracksucht.de.      2325    IN      A

;; Query time: 66 msec
;; WHEN: Mon Oct 16 19:07:19 CEST 2017
;; MSG SIZE  rcvd: 124

And then

ssh [email protected] -p 2222
ssh: connect to host port 2222: No route to host
ssh -p 2222
ssh: connect to host port 2222: No route to host
ssh -p 2222
ssh: connect to host port 2222: Connection timed out
ssh -p 2222
ssh: connect to host port 2222: No route to host

What is wrong? Is it the part of the exercise (which I do not understand at all)? Or its just does not work? Thank you.

3 Answers 3


You definitely has firewall issue between you and remote host you trying to access.

You can get ping response from remote host because ICMP traffic are allowed by firewall but TCP traffic has some blocking based on rules on firewall. Try contacting different service on remote host like http or https or ftp etc if possible.

You can use 'traceroute' program to see if UDP traffic is allowed. Some Linux distribution comes with SSH service dropped by default firewall rules. Best way is to contact remote host admin/user to be sure that your IP is allowed.

Are you sure remote host running. SSH service on port 2222 not 22 ?? You are connecting ssh on 2222 port with -p option on your command


Your "no route to host" while the machine responds to ping is a sign of a firewall that is denying you access but is informing you that it happened (i.e. with an ICMP message rather than just silent drop).

Check your outgoing firewall. If it isnt that then its blocked closer to the destination.


I encountered a similar situation: On a k8s hosts using flannel, podA can ping podB on the same host, but tcp connection was reset by a ICMP reset from cni0. iptables-save shows rule about k8s, and all of them works look fine. nft list ruleset shows rules made by firewalld:

table inet firewalld {

    chain filter_FORWARD {
        type filter hook forward priority filter + 10; policy accept;
        ct state { established, related } accept
        ct status dnat accept
        iifname "lo" accept
        ip6 daddr { ::/96, ::ffff:, 2002::/24, 2002:a00::/24, 2002:7f00::/24, 2002:a9fe::/32, 2002:ac10::/28, 2002:c0a8::/32, 2002:e000::/19 } reject with icmpv6 addr-unreachable
        jump filter_FORWARD_ZONES
        ct state invalid drop
        reject with icmpx admin-prohibited

All works fine after stop the firewalld service: systemctl stop firewalld So, try to check if other service or kernel modules that may using netfiler as well.

  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jul 6 at 10:08
  • What the bot is telling you is to please explain what this does and/or why it works. Otherwise your answer may get deleted. Jul 6 at 10:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .