16

I am getting wrong favicons when I bookmark sites in Firefox 56.0 (64-bit).

For example, when I bookmark Stackoverflow.com, I get a favicon for Reddit.com.

Any idea why this would be, or how I can fix it?

Note: This is the only site this is currently occurring with, but it happens every time when I remove/re-add the bookmark.

Stack Overflow Showing Reddit favicon:

Stackoverflow Showing Reddit Favicon

Correct favicon Shown in Media Tab:

Correct Favicon Shown in Media Tab

Edit 11/25/17

Happening now on Drudge.

The accepted answer below does fix it.

Drudge Wrong Favicon

  • Have you tried reinstalling Windows? – random Oct 16 '17 at 19:05
  • 10
    @random Reinstall Windows? Seems extreme to go there right out of the gate. – CharlieRB Oct 16 '17 at 19:24
  • 4
    @random You must be joking. – Patrick Oct 16 '17 at 23:54
  • I used to have an add-on to reset favicons, but it is no longer supported. You can check thru the current add-ons, but this one indicates it is no longer possible. FavIcon Reloader up to FF 48 only and Developer reply by miacdo – user3169 Oct 18 '17 at 5:31
  • 1
    This used to occur frequently in older versions, and suddenly the issue has reappeared for me. If I remember correctly, clearing one of the tables in the SQLite databases could fix it for a while. But I don't think anyone discovered the underlying cause. – Stijn Nov 21 '17 at 9:01
13

Close firefox, delete %AppData%\Mozilla\Firefox\Profiles\<your profile>\favicons.sqlite

This is easier to do than peqhusus's solution, but it does mean you'll lose all cached favicons and have to reload your bookmarks to get the icons again.

  • This is an easier solution, as you mentioned, and fixes the issue, including between restarts. Thanks. – Patrick Jan 20 '18 at 13:29
  • For the records, that only exists starting from Firefox 55. Before that (or well, at least since version 3) favicons were inside a table in places.sqlite. Which one should be very careful to handle when downgrading/updating around FF 52-57. – mirh Feb 22 at 13:31
3

This may not be the best solution if you are only slightly annoyed...

What I usually do when this happens is go to

Bookmarks --> Show All Bookmarks --> Import and Backup --> Export Bookmarks to HTML file

Then open the bookmarks file, find the corresponding bookmark entry, then change ICON_URI="{URL}" ICON="data:image/png;base64,{data}

to the URL of the icon and the base 64 encoded icon in png format

Then import the modified bookmarks file back into Firefox

  • Thanks, this DOES fix the issue, but is obviously not for your average end-user. This was not presenting itself again until today, where I now had my Drudge Report bookmark toolbar completely disappear (although it was listed in the sidebar if I checked bookmarks). So I removed and re-added, and get (oddly enough) the Reddit favicon for Drudge. – Patrick Nov 25 '17 at 20:19
-1

Clearing the web cache should force Firefox to download the favicons again.

  1. Close all the tabs except a new one
  2. Go to Tools > Options
  3. Click the Advanced on the left panel, then the Network tab
  4. Find Cached Web Content and click the Clear Now to the right
  5. Restart Firefox
  • 2
    Didn't do it. For the record, Firefox 36 doesn't have an Advanced tab on the left panel anymore. However, I did locate the clear Cached Web Content. I restarted, yet still get a Reddit favicon for StackOverflow. Perhaps I should file a bug with Mozilla? – Patrick Oct 16 '17 at 23:58
  • 1
    It seems the "Clear Cached Web Content" only clears page data. My favicons did not reload (from what I could tell) ... they were all there instantly when the browser loaded. – Patrick Oct 16 '17 at 23:59
  • 1
    Your question states version 56, not 36. Which is it? Do other browsers load the favicons correctly? – CharlieRB Oct 17 '17 at 11:42
  • 1
    That was a typo. It's the latest Firefox 56 fully updated. – Patrick Oct 17 '17 at 14:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.