0

I have an HP Laptop that has Windows 10 and a touch screen. The problem is it constantly clicks in about 10 different spots. Before it got really bad I was able to disable the hardware in device manager but now it is too difficult and I can not even log in.

There does not seem to be any way to disable this with the function keys, bios, I even tried using another display but the touch screen clicks still propagate to the new screen even though I am trying not to use the laptop screen.

Any help would be appreciated.... Like I said I can not use device manager as I can't even log in... and if I did get in I would not be able to navigate windows as the mouse clicks are just too much.

  • Two suggestions: 1. Clean the touchscreen, including edges, with 90% or stronger isopropanol. Avoid any trickling inside, and dry carefully. 2. If that doesn't work, try booting from a Linux distro without touchscreen drivers. You might be able to disable (rename) the Windows touchscreen driver, or at least run Linux, installed or from Live USB/CD. – DrMoishe Pippik Oct 17 '17 at 23:39
  • Unfortunately the digitizer or more likely the controller board has gone bad. You can unplug it from inside the computer or inside the screen. It's up to you if you think you are able to do that. Have you tried closing the lid completely when you have the external monitor hooked up? The laptop will probably go in to standby, but maybe your model exposes the power button even when the lid is closed? I'm not sure if running running with the lid closed will disable the digitizer. I don't think so, but worth a try. – Appleoddity Oct 18 '17 at 4:14
  • @DrMoishePippik already tried that. Thanks for the advice. – NewfrontSolutions Oct 18 '17 at 12:18
  • @Appleoddity it is an old POS laptop but has some data on I would like to get out so I may try to open it up to detach the digitizer. If not I will just remove the harddrive and get my data through another computer. – NewfrontSolutions Oct 18 '17 at 12:20
  • Finally got it working.... Squeezed the screen really hard.... made it way worse for a while..... restarted and was able to log in.... then it got really bad for a while again and I couldn't do anything.... then I had a break from the clicking and was able to disable it in device manager. Next windows update I will have to try to do this again.... might take @DrMoishePippik advice and install linux next time it happens. At least I will be able to get to a command prompt with no mouse then. – NewfrontSolutions Oct 18 '17 at 13:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.