5

I need some help for a problem regarding Gnome file search:

I can't find most files in Gnome Activities search even if those files are correctly indexed and found by tracker. As you can see from the image below, tracker-needle correctly finds the 'ciao' directory, while the shell doesn't. Is tracker the "File" search provider? If so why results do not appear?

On Debian 9 stretch, Gnome 3.22.2

6
+50

Why doesn't Gnome Search find your files?

Well, by default Gnome only indexes files which reside directly in your home directory or in the folders Desktop, Documents, Downloads, Music, Pictures and Videos.

Is there some way to search in other folders?

Yes, there is.
To add a folder to the index open gnome-control-center, open the "Search" menu, click on the little gearwheel symbol and switch to the tab "Other". Now you can add a folder of your choice by clicking on the plus symbol, unfortunately this works only for folders located on the same drive as your home folder.

How to index files located on a different drive than your home folder?

For that you need to bind the directory you want indexed to a folder located on home's drive.

For example use:

cd ~/
mkdir ./searchdirectory
sudo mount --bind /some/directory ./searchdirectory

To make it permanent you would need to write a new entry to "/etc/fstab".

For example like this:

/some/directory /home/youruser/searchdirectory none bind 0 0
  • 3
    Thanks for this detailed answer. For me, the gearwheel symbol is disabled (using Ubuntu 17.10) – do you have an idea what's the reason for that? – Felix Edelmann Oct 28 '17 at 11:56
  • And is there a way to enable recursive search? – Felix Edelmann Oct 28 '17 at 12:00
  • 2
    @FelixEdelmann Looks like the greyed out gearwheel is a bug in Ubuntu. – testeaxeax Oct 29 '17 at 17:25
  • @FelixEdelmann What do you mean by "recursive search"? Gnome is searching recursively in all search locations except the home directory. – testeaxeax Oct 29 '17 at 17:31
  • 1
    @FelixEdelmann As a workaround you could bind the directory you want indexed to a folder inside Documents, which is one of the default search locations, and so you wouldn't need to access the gearwheel menu. – testeaxeax Oct 29 '17 at 17:37
1

It seems the wheel is not enabled if you do not have "tracker" installed. Tracked indexes files on your disk. This is not enabled in ubuntu by default.

sudo apt install tracker

See this bug (not sure I agree its a bug though). Found this be reading a bit down the bug-link provided by @FelixEdelmann

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.