2

Sometimes I accidentally put my arm on the Numpad Enter when coding and when the enter key starts repeating, things get messy. I use Windows 7 on a desktop computer and my keyboard is a DELL standard USB keyboard. I want to know if I can disable keyboard repeat just for the Numpad Enter key.

  • 1
    Not to my knowledge. You can change it for all keys, as the answer provides, but not for a single key. Maybe a better approach is to buy a rubber band and put it around your wrist. Every time you hit that button, you pull it and release it. Yes, that is supposed to hurt. – LPChip Oct 19 '17 at 9:45
1

You need to use Accessibilty Options in the Control Panel in order to achieve that.

  1. Go to Start, Control Panel.
  2. Choose Accessibility Options. (Depending on your Control Panel view, you may need to choose Accessibility Options again at the next screen listing Tasks or you may go directly to Options settings below.)
  3. On the Keyboard tab, check "Filter Keys" and click "Settings" button.
  4. Select "Ignore Quick Keystrokes" and click "Settings" button.
  5. Select "No Repeat ..." at the bottom of the box, adjust the "Keys Must Be Held ..." time to 0.0 (so the key will still type as soon as you hit it.)
  • BTW, this is a global solution. There is no other methods for predefined keys that I know of... – Mehper C. Palavuzlar Oct 19 '17 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.