16

Everything worked correctly on my IIS, but I installed Windows Fall Creators Update and everything stopped working.

I get an 503 - Service Unavailable error on every app and page inside my AppPool I visit. I've checked the Windows event viewer and it says the following:

Windows Event Viewer - Error description

I've searched among the web and none of the solutions work (permissions, credentials...). I've even uninstalled completely IIS (with WAS included) and reinstalled it to reset to its factory settings. All my applications now are gone (as expected), but I still get the same error.

My system is a Windows 10 Pro (version 1709) Lenovo laptop. No updates are available on Windows Update.

More information of the error on Event Viewer:

Event Viewer more information

What's wrong with my IIS configuration and how can I make it to work again?

Any further information you may need, please ask and I'll write it down!

Thank you!

  • 1
    This is documented here by this KB: support.microsoft.com/en-us/help/4050891/… I am curious; did you get upgraded through Windows Update offering you to upgrade with a notification? Or did you manually upgrade through other means? – bariscaglar Oct 25 '17 at 0:28
  • @bariscaglar So far I have hit this problem using the manual installer and the windows update (not on my machine on the latter, but on a coworker) – Robson Rocha Oct 27 '17 at 7:36
35
+50

The issue is related to the temporary symbolic links created for the application pools by IIS/WAS being messed up during the Windows Update process for installing Fall Creators Update.

The steps to solve the problem are (at an administrator powershell):

Stop-Service -Force W3SVC
Stop-Service -Force WAS
Foreach($item in Get-ChildItem C:\inetpub\temp\appPools){
  if([IO.File]::Exists($item.FullName)){
    Remove-Item $item -Force
  } else {
    [IO.Directory]::Delete($folder.FullName,$true);
  }
}
Start-Service W3SVC 
Start-Service WAS

Deleting everything (files, folders and shortcuts) under "c:\inetpub\temp\apppools" will clear the temp files and the incorrect symbolic links, and starting IIS/WAS again should create them back and fix the issue.

Edit Microsoft have documented the issue in the following KB: https://support.microsoft.com/en-us/help/4050891/error-http-503-and-was-event-5189-from-web-applications-on-windows-10

  • 1
    Thank you! Not only the files stored there, but also had to delete a folder shortcut to DefaultAppPool. After that (and reconfiguring the IIS due to the factory reset I made), it's working now!! – Unapedra Oct 20 '17 at 14:50
  • 1
    Yep, I had to delete the folder shortcuts as well. Works now! – Chris Hynes Oct 20 '17 at 15:28
  • 1
    While I don't think it's problematic to delete all the files in appPools folder, you can just delete the subfolder of the problematic Application Pool name as indicated in the error message. – LongZheng Oct 24 '17 at 5:55
  • 1
    @LongZheng: The problem is that, after the Fall Creators Update installation, all AppPools become problematic. – Robson Rocha Oct 24 '17 at 11:09
  • 7
    We've hit this at Stack Overflow across so many devs and designers now. Thanks so much for posting a solution, it will save everyone here a ton of time and frustration. – Nick Craver Oct 26 '17 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.