0

Mission was to update to 42.2 from 42.1. I followed this guide: https://kamarada.github.io/en/2016/10/31/how-to-upgrade-from-opensuse-leap-421-to-422/#.WejmLXUxC00

I've made a backup for repos:

Fri Oct 20; 12:13:13; marton;/etc/zypp/repos.d.old ;  $  ls -l /etc/zypp/repos.d.old
total 92
-rw-r--r-- 1 root root 173 Oct 19 20:02 Code::Blocks.repo
-rw-r--r-- 1 root root 125 Oct 19 20:02 dvd.repo
-rw-r--r-- 1 root root 171 Oct 19 20:02 ftp.gwdg.de-suse.repo
-rw-r--r-- 1 root root 180 Oct 19 20:02 http-download.opensuse.org-064ceb96.repo
-rw-r--r-- 1 root root 179 Oct 19 20:02 http-download.opensuse.org-47bc4ea5.repo
-rw-r--r-- 1 root root 184 Oct 19 20:02 http-download.opensuse.org-5e3af6ac.repo
-rw-r--r-- 1 root root 187 Oct 19 20:02 http-download.opensuse.org-8623a395.repo
-rw-r--r-- 1 root root 250 Oct 19 20:02 http-download.opensuse.org-89f7d7bc.repo
..

I've deleted all the repos, but these:

Fri Oct 20; 12:20:13; marton;/etc/zypp/repos.d.old ;  $  ls -l /etc/zypp/repos.d
total 0
-rw-r--r-- 1 root root 0 Oct 19 20:36 repo-oss.repo
-rw-r--r-- 1 root root 0 Oct 19 20:36 repo-update.repo

Fri Oct 20; 12:12:42; marton;/usr/lib ; $ sudo zypper ref root's password: sudo: unable to write to /var/lib/sudo/ts/marton: No space left on device Warning: There are no enabled repositories defined. Use 'zypper addrepo' or 'zypper modifyrepo' commands to add or enable repositories.

So I am trying manualy to add repos:

Fri Oct 20; 12:20:48; marton;/etc/zypp/repos.d.old ;  $  sudo zypper addrepo --check --refresh --name 'openSUSE-Leap-42.2-Update' http://download.opensuse.org/update/leap/42.2/oss/ repo-update
root's password:
sudo: unable to write to /var/lib/sudo/ts/marton: No space left on device
Adding repository 'openSUSE-Leap-42.2-Update' .........................................[done]
Repository 'openSUSE-Leap-42.2-Update' successfully added
Enabled     : Yes                                               
Autorefresh : Yes                                               
GPG Check   : Yes                                               
Priority    : 99                                                
URI         : http://download.opensuse.org/update/leap/42.2/oss/

Fri Oct 20; 12:34:10; marton;/etc/zypp/repos.d.old ;  $  sudo zypper addrepo --check --refresh --name 'openSUSE-Leap-42.2-Update' http://download.opensuse.org/up
root's password:
Fri Oct 20; 12:35:29; marton;/etc/zypp/repos.d.old ;  $  sudo zypper addrepo --check --refresh --name 'openSUSE-Leap-42.2-Oss' http://download.opensuse.org/update/leap/42.2/oss/ repo-update
root's password:
sudo: unable to write to /var/lib/sudo/ts/marton: No space left on device
Adding repository 'openSUSE-Leap-42.2-Oss' ............................................[done]
Repository 'openSUSE-Leap-42.2-Oss' successfully added
Enabled     : Yes                                               
Autorefresh : Yes                                               
GPG Check   : Yes                                               
Priority    : 99                                                
URI         : http://download.opensuse.org/update/leap/42.2/oss/

But still I get this:

Fri Oct 20; 12:31:58; marton;/usr/lib ;  $  sudo zypper ref
sudo: unable to write to /var/lib/sudo/ts/marton: No space left on device
Warning: There are no enabled repositories defined.
Use 'zypper addrepo' or 'zypper modifyrepo' commands to add or enable repositories.

But I just enabled them... I can't access YAST for some reason...

So, I have to make so these repos are enabled, probably, but how? Should I restart my PC ? Does this line after every command have to do something with the problem:

sudo: unable to write to /var/lib/sudo/ts/marton: No space left on device

Is there another way to enable these repos ?

How do I procede in updating my machine ?

0

1 Answer 1

0

The disk is full. This frequently is a problem with there being many snapper snapshots saved. Yast has an interface to manage and delete snapshots. Otherwise, from the terminal window, you can:. df to see if the disk really is full. sudo snapper list to see the snapshots. sudo snapper rm XXX where XXX is the # of the snapshot on the list. I never have had a problem from deleting snapshots, only from letting them pile up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.