9

I'm trying to set Firefox as the default browser on a Windows 10 PC and when I go to Settings => Default Apps the only options that appear are Edge & IE. Is there a way I can bypass this UI and simply manually select an .exe?

I did see this question and tried the solution listed there (create a .htm file, assign Firefox to open all .htm files) but Settings => Default Apps still does not list Firefox as an option.

Apologies if proper etiquette 'round here is to necro an old question instead of re-asking.

EDIT: I am trying to make set Windows' default web browser to Firefox. This is normally done via Settings => Apps => Default Apps but for some reason Windows is not listing Firefox as an option.

  • What, exactly, do you mean by “set Firefox as the default browser”?  Do you mean that you want Firefox to open when you double-click on an HTML file in Explorer?  Does that work?  What behavior that you want are you not getting?   Please do not respond in comments; edit your question to make it clearer and more complete. – G-Man Oct 20 '17 at 15:02
  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. – Ramhound Oct 20 '17 at 15:19
  • 3
    I think it's time for a second 'suit - Microsoft browser v.s. Microsoft browser is no choice at all. :-) – wizzwizz4 Oct 20 '17 at 19:46
  • Did you install Firefox as an administrator or as a normal, limited user? I'm asking because I had the same problem with Chrome on Windows 7, and the solution, as I posted here, was to reinstall Chrome as an administrator. Could it be that it's the same problem? – Fabio Turati Oct 21 '17 at 0:07
  • Just to add a tidbit, this also seems to happen on PCs at work after the 2017 fall edition update. Firefox works perfectly, but is not settable as the default browser until it is deinstalled and reinstalled. – Hennes Jun 14 '18 at 18:34
10

I have the same issue on my PC, with Firefox not being listed in the Web browser section of the Default Apps part of Settings. However, you can still change Firefox to the default web handler from this screen; it just takes a few extra steps.

  1. From the Choose Default Apps screen, scroll all the way down to the bottom and click on Set defaults by app.
  2. In the following window (located at Control Panel\All Control Panel Items\Default Programs\Set Default Programs) choose Firefox from the list of programs.
  3. At the bottom of the window, click on Set this program as default. This will select all options that Firefox would normally set if you clicked the Make Default button in FF before Windows 10.
  4. Alternatively, you can click Choose defaults for this program and select only the files/protocols you want Firefox to respond to.

For me, this sets Firefox as the default web browser for everything I want, though for some weird reason it still won't list it as an available option in the Web browser section.

  • For me, Firefox doesn't show up in that list either. – JiK Jun 10 at 8:45
6

Using the portable version of Firefox, I was able to make it appear in the list of web browser choices found at Settings -> Apps -> Default apps.

Within Firefox itself, navigate to Tools -> Options -> General press Make Default...:

enter image description here

I found the same behaviour with an installed version of the Firefox-based PaleMoon browser, so I doubt if my use of portable Firefox has any effect on the solution, but Run5k was right to point out that I should have noted this.

Earlier versions of Firefox may have this setting elswhere (eg Options -> Advanced -> General).

  • When I do this in Win10 and FF 52.4 ESR it does not set Firefox as the default. It just takes me to the place where you are supposed to change all your main default apps, but as with OP, I don't have FF in my list under the web browser section. – techturtle Oct 20 '17 at 15:58
  • Yeah I get the same thing as techturtle. That opens Windows' Settings => Default Apps but the dropdown for Web Browser still just lists IE and Edge – gohanman Oct 20 '17 at 16:03
  • Very odd. When I use this option I go to the same place, but Firefox has been added to the list of available programs. I found the same with PaleMoon and Chrome. Have you got a security setting which is preventing this? – AFH Oct 20 '17 at 16:29
  • AFH, I know that you had the best of intentions with your answer, but the bottom line is that you can't really "make the setting from within Firefox itself." Utilizing that method merely opens the same Settings > Default Apps interface, rather than actually changing anything. – Run5k Oct 20 '17 at 16:37
  • @Run5k - What it changes for me is the list of available apps. – AFH Oct 20 '17 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.