1

I have 2 drives:

  • disk1 (SATA SSD, with Ubuntu 16.04)
    • partition1 (sda1: flag /boot)
    • partition2 (sda2: flag /home, encrypted by LUKS)
  • disk2 (NVMe SSD)

So, the goal is to install Windows 10 on disk2 and boot it from GRUB (which is on sda1).

What is the problem ?

In disk-choose step, disk2 is missing. However Ubuntu 14.04 installer "see" this disk, so I assume that is software issue, rather than my hardware.

What I tried to solve this problem ?

  • loaded Samsung NVMe drivers from this thread
  • patched Windows image using DISM tool by adding 2 updates. I followed this guide
  • tried to run Windows 10 installed on USB stick to install it

All of them failed.

Please help me to solve this issue.

  • you need to add the driver to the boot.wim not install.wim. have you done this? – magicandre1981 Oct 21 '17 at 17:49
  • @magicandre1981 yes, I linked guide for this. – werasquez Oct 21 '17 at 17:55
  • which win10 build do you use? – magicandre1981 Oct 21 '17 at 18:04
  • @magicandre1981 mainly i tried intsall Windows 10 Professional N but somtimes I tried with Windows 10 Professional (N version doesn't include Windows Media Player, thats all difference) – werasquez Oct 21 '17 at 18:14
  • this is the edition/SKU. I mean the version/build (v1507/Build10240 or v1511/Build 10586 or v1607/Build 14393 or v1703/Build 15063 or the newest v1709/Build 16299? Try the newest version if possible. it always has best HW support. – magicandre1981 Oct 22 '17 at 8:01
0

So. The solution is:

When arrive at the custom advanced screen during setup, press Shift + F10

type the following commands

DISKPART

Hit Enter

list volume

Next you will select the volume where you would like to install Windows 10 Type: select disk #

# represents the number the volume

Type: clean

convert mbr

create partition primary

active

format quick fs=ntfs

exit

exit

And next:

Select the drive, click Delete

This will convert it to unallocated

Select it, click New

It should create additional partitions (system reserved and primary)

Select the primary drive then click Next

  • looks like the drive was UEFI/GPT formatting but you created a MBR stlyle uSB drive – magicandre1981 Oct 22 '17 at 17:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.