9

I'm working on a MacBook Air with a really peculiar problem. When using it to copy video files larger than 2GB to a USB drive, it fails with the error:

The item can't be copied because it is too large for the volume's format

I tested by transferring around 10 video files of varying sizes to a 128GB flash drive. Those that were under 2GB succeeded and those over it failed.

To rule out the USB being faulty, I also did the same on another 8GB flash drive, which had the same problem. Both flash drives show up in MacOS as MS-DOS (FAT32).

In addition, this issue only seems to apply to MacOS, as transferring the same files to the same USB sticks from my Windows 7 machine largely succeeded, with the only transfer limitation being FAT32's usual 4GB file limit.

Does anyone have an idea what's going on here?

  • 2
    I don't know. But I found this thread which may be helpful. – SpiderPig Oct 21 '17 at 23:52
  • That's a brilliant find, I tried several variations of Google searches but still didn't manage to come across that link. With me being at least the third person in a day to report this problem after the rollout of a new MacOS version, it also seems a relatively conclusive answer to my question. You should post it as an answer. – Prometheus Oct 22 '17 at 0:57
  • Mercifully, as long as you know the file is < 4GB, the cp command works. – Timothy Makobu Dec 16 '17 at 11:12
  • @timkofu - The bug is with Finder, so any way of handling the file that isn't Finder - whether an alternative file manager like TotalCommander or the native bash command line - will work fine. – Prometheus Dec 20 '17 at 4:26
17

This is a bug in the current version of macOS 10.13 High Sierra.

For now don't use Finder.app to transfer files larger than 2 GB to a FAT32 formatted volume/drive as the operation will fail.

In the meantime use other file managers such as ForkLift, Transmit or Commander One to copy larger files to FAT32 volumes.

| improve this answer | |
  • 1
    Just used ForkLift. Super awesome. – xySVerma Dec 26 '17 at 8:36
  • 2
    Wow, thanks! I was suspecting my USB key to be corrupt and spent half an hour doing disk checks and reformats. Apple has a really bad year on Mac. – Tomáš Kafka Dec 29 '17 at 22:10
1

Thanks to SpiderPig for finding conclusive evidence that this is a bug in MacOS High Sierra - namely, this Reddit thread created within the past few days, which has a few users attesting to it.

For additional context, I thought I'd add the results of my research since asking this question. This particular bug is the latest in a long list of bugs introduced by High Sierra, and is apparently so minor/rare relative to others that it hasn't registered on any of these non-comprehensive lists of them. It has, however, been reported in that last MacRumors thread by myself and at least one another user, so it will hopefully be added to that list soon.

Until Apple eventually releases the update that fixes it, there are two workarounds for this bug.

Convert your flash or external drive to exFAT

You can convert the FAT32 flash drive or external drive that you're having trouble with to exFAT, which is a newer, more superior filesystem with file limits that are so large they can (currently) be considered non-existent.

The only real downside to this solution is that exFAT's relative newness compared to FAT32 will make it incompatible with certain less popular hardware, although it was still released in 2006, so this is increasingly inapplicable. I'd recommend trying to convert to exFAT first and see if the hardware you need to use your flash drive or external disk on supports it. If it does, you're good to go, and if not, you can simply convert back to FAT32.

As far as I'm aware, there's no way to convert to exFAT non-destructively (i.e. without data loss), so you'll need to backup all the data on your drive before formatting the drive in the usual way via Disk Utility, and then transfer your data back once the format is complete.

Use another file manager

This bug doesn't seem so much to be a problem of the APFS filesystem that High Sierra introduced - its replacement to HFS+ - but of Finder itself. For that reason, as oa pointed out in his answer, the bug can also be worked around for now by simply using an alternative file manager like Transmit or Commander One1 until Apple decides to release the fix.


1 Speaking of Commander One, a tangentially related side-note: if, as of the time of posting this answer, you currently have Eltima's Elmedia Player or Folx installed on your Mac, you should follow the instructions here as soon as possible

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.