2

After installing the latest stable for passenger-enterprise, my server faced an unknown error:

Required key 'ust_router_address' is missing (-1: Unknown error)

The effect on the server was surprising: the apps would start (and nginx restart command returned an ok) but the users would receive a "403 Forbidden". Looking at the log it appeared that my user was apparently unable to access the app root folder (/var/www/../public) despite correct (and unchanged! permissions).

I contacted support but no word yet, and as a temporary workaround I reverted to the previous version (via sudo apt-get install passenger-enterprise=1:5.1.8-2~trusty1 and a nginx restart) which works seamlessly.

Any insight much appreciated, when I look at the doc ust_router_address is supposed to be set by passenger automatically.

Thanks in advance.

  • Update from support saying that: " it looks like you may still have a union station config option set, which have been removed from Passenger. Those options are prefixed with union_station_, or are set with passenger_ctl in the nginx config and use the prefix ust_. " in case it helps anyone. In my case unfortunately I've neither set, so not sure, still investigating. – thomasstephn Oct 23 '17 at 14:24
0

I didn't have enough reputation to make this a comment. I have created an issue on https://github.com/phusion/passenger/issues/2000

I encountered this error as well, using

libapache2-mod-passenger       1:5.1.11-1~trusty1   amd64
passenger                      1:5.1.11-1~trusty1   amd64

It failed on a graceful restart (during log rotate) with the following error

[Thu Nov 02 06:28:28.257749 2017] [passenger:error] [pid 1916:tid 140125707691904] *** Passenger could not be initialized because of this error: Required key 'ust_router_address' is missing

After restarting, it came back up showing no problems, no configs were changed. We don't even use Union Station.

0

As this is the top hit on Google for this question, and if you don't have the time to go through the Passenger bug report, the solution is to STOP your running nginx/apache service, and then START it. i.e. don't simply do a reload (which probably happened when you upgraded Apache), but make sure the old service is completely gone, then start it:

e.g. sudo apache2ctl stop then sudo apache2ctl start

(I was seeing version 5.1.8 in the log, even though the upgrade took me to 5.1.11 ... this is the clue that the old Passenger is still hanging around)

0

After more investigations and thanks to the passenger support team, I managed to fix the issue.

What ultimately worked was to update nginx-extras to the latest version which did not rely on any 'union_station_' type of config.

apt-get update && apt-get install nginx-extras

Hope that helps whoever comes along this.

-1

I had same or similar issue, which I solved by restarting apache2.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.