6

Microsoft Word underlines grammatical errors (in blue) by default. After choosing to ignore grammatical errors and opening the document again, the blue lines are there again. How can I permanently ignore grammatical errors?

Steps to reproduce the issue:

  1. Create a new .docx file.
  2. Write "Tiger was killed by hunter."
  3. You will see a blue line under "Tiger was killed by hunter."
  4. Click "Spelling and Grammar" under review tab. (Or right-click the word)
  5. It will say your sentence is in passive voice.
  6. Click "Ignore".
  7. The blue line is gone.
  8. Close the document.
  9. Open it again
  10. The blue line points out the error again.

The blue line is why I cannot ignore this, why I need a permanent fix.

  • Is it an actual error, or is it that it's being incorrectly flagged? – djsmiley2k TMW Oct 22 '17 at 18:03
  • Its a actual error. But once I ignores it, it should not show up again even if I close/open a document. – Abhishek dot py Oct 22 '17 at 18:05
  • The ignore only works for that instance - so, if you want it to go away permanently then correct the grammar. – Solar Mike Oct 22 '17 at 18:15
  • Yes, I know that. I am talking about single instance only. Its not just incorrect grammer. It is showing blue line for passive voice also. I have ignored it, but everytime I opens the document, it comes again. This has started happening since yesterday. Earlier it was working fine. – Abhishek dot py Oct 22 '17 at 18:21
  • 1
    Ignoring spelling errors has always been temporary and per-session. It is possible that proof-read on your Word client was broken in some way before and has now been "repaired". – music2myear Oct 23 '17 at 19:17
1
+50

Doing a brief bit of research it appears that the standard behavior (going back at least to Word 2007) is for ignored spelling and grammar issues to be only per-session. Subsequent checks will flag the same errors once the file has been reopened.

What is also apparent is that the checking engine was not always reliable in re-flagging these previously-ignored errors.

In other words, you were previously benefiting from an error, and now the error is no longer occurring.

See here for further discussion of this, including a 2nd-hand report from MS Devs on the issue: https://arstechnica.com/civis/viewtopic.php?t=1197433

  • Oh man. Is there a work around. I do not want to go and ignore it everytime. My document have more than 100 pages and it keeps increasing. – Abhishek dot py Oct 23 '17 at 20:57
  • 1
    Turn off grammar checking. The workaround suggested in the linked forum thread suggests creating a document template that disables grammar check. You can still turn it on on-demand. – music2myear Oct 23 '17 at 21:14
  • You were right. I checked with a Microsoft Guy. He says the same. – Abhishek dot py Nov 6 '17 at 18:58
1

Although it is not possible to permanently ignore Grammar or Style errors, you can fine tune MS-Word's spell check to your personal writing style.

This will help prevent a lot of blue/green lines from appearing on the 100-page document.

Go to File > Options > Proofing

  • Configure if MS-Word should check for "Grammar Only" or "Grammar & Style"

and/or

  • Configure further under Settings, to enable or disable options such as "Passive sentences" and "Hyphenated and compound words".

Fine tune Word's spell check using the options under Settings

Once you have configured the settings, you may want to click on Recheck Document / Check Document to see the effects and modify the settings further as needed.

1

You can permanently get rid of this errors once and for all by turning off "Mark grammar errors as you type" and "Check spelling as you type".

HOW: File > Options > Proofing > under "When correcting spelling and grammar in Word" > uncheck "Mark grammar errors as you type" and "Check spelling as you type".

This will completely solve your problem with every phrase even after reopening the file.

Here are the images:1-with error checking 2-without error checking

0

Here are a couple of ways you may avoid such repeating grammar errors.

  • If the problem concerns the way a single word is used, for example using "staff are" when Word insists that "staff" is singular, add the word "staff" into
    File > Options > Proofing > Auto Correct Options > Exceptions > Other Corrections.

  • If the problem concerns a phrase whose grammar you don't want to be checked, select that phrase and then in in the Review tab, in the Language group, click Language, then click Set Proofing Language, and finally click the Do not check spelling or grammar check-box to enable it and click OK.

0

Have no fear! This can be done.

  • You do NOT need to turn off grammar (and/or spelling) checking for your document.
  • You do NOT need to disable any rules.
  • You do NOT need to add it as a "global" exception.

Word can be told to "ignore" any grammar (or spelling) "oddity" that you want.

It will then ALWAYS remember to ignore that "oddity" (yes, across close and re-open, too).

However, if you have additional grammar/spelling errors elsewhere, Word will still catch them.

Here's how:

  1. Select the word or phrase in question.

  2. Navigate to the "REVIEW" tab.

  3. Click on the "Language" button.

  4. Choose "Set Proofing Language" from the drop-down.
  5. In the small window that pops up, place a check mark in the box for "Do not check spelling or grammar"
  6. Click OK.

HTH!

~spammy

How to turn off spelling & grammar check for a single selection of text

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.