I have Windows 7 and an NVIDIA GTX 980 video card. As you know DisplayPort has this stupid autodetect feature which cannot be disabled in the OS, where when you turn a DisplayPort screen off, it disappears from the system, which jumbles up all my windows, etc. So, I'd like to find a way to put it to sleep (turn off the display) without actually disabling it.

I want to point out some things that won't work or are unsuitable for me (so, please, don't recommend them):

  • Just blanking the monitor. I know this can be done, there's a handy utility called Multiscreen Blank that does that, but it just covers it with black color. It still illuminates a bit (especially when I watch a movie in a darkened room), it still drains power, and it doesn't affect the task bar which is not always desirable. I want the display to actually stop emitting light.

  • Using monitor's built-in features. Some monitors have an internal option to disable hotplug autodetect. Unfortunately, my AOC doesn't.

  • Making it the main monitor. It could work, but unfortunately it's not suitable for me because its colors and image are a bit worse than my main Acer monitor, so I can't use it as the main one.

  • Using EDID hacks. That option is unavailable for GTX 980.

  • Using stuff like MultiMonitorTool. It DOESN'T have that option. It only has an option to turn the monitor off from the command line, which triggers the damn autodetect, so it's useless for me.

  • Using Nircmd. Unfortunately it can only put all monitors to sleep together. It's very useful when I need to do just that, but it can't do that to individual screens. However, the fact that it can do it to all monitors without triggering autodetect tells me there must be a way to do it for one monitor only.

If there's any answer apart from the mentioned above (that don't work), I'd be exceedingly grateful. So far I've been unable to find anything.

  • Have you looked at Turning DisplayPort monitor off disables monitor completely and the other related questions? – Scott Oct 22 '17 at 20:40
  • I'm pretty sure I've checked everything. The only solution that seemed viable was blocking on the pins with electric tape which wouldn't work for DisplayPort anyway and I can't switch to hdmi because it's occupied by a TV used as a third monitor. Besides, hdmi doesn't trigger this for me anyway. – Anton Akopov Oct 22 '17 at 22:05

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.