14

I work most of the time with my Windows 10 laptop (Lenovo X1 Carbon, 2012 1. gen model) closed and an external monitor attached.

To achieve this I have to start the computer by

  1. opening the lid,
  2. press the start button,
  3. wait until it booted and
  4. the external monitor is active, then
  5. close the lid which puts the laptop into sleep after which
  6. I can hit a mouse button or key to make it "start" (unsleep) again

Of course this is a bit silly.

On the other hand I also work mobile, with no external monitor. One thing I can not compromise on is that the laptop indeed has to go into sleep when I close the lid (~ 15 years of conditioning).

Is there a better way to turn my laptop on if an external monitor is attached?

  • What brand / model of laptop would be helpful. Get a docking station, if ones available. – Appleoddity Oct 23 '17 at 12:19
  • Updated the question: Lenovo X1 Carbon, 2012 model. Unfortunately the docking station is a bit expensive :/ Especially for such an old machine. – janpio Oct 23 '17 at 12:24
12

EDIT:

Wake-On-Mouse

  1. Change what closing the lid does by setting it to 'Do Nothing':
    • Hit the ⊞ Win key and type lid, or else go:
    • Control Panel → Hardware & Sound → Power Options → System Settings
  2. Plug in an external mouse.
  3. Go to Device Manager or hit ⊞ Win + X followed by M
  4. Double-click the external USB pointing device.
  5. On the Power Management tab, ensure that Allow device to wake computer is checked.
  6. When you're finished using the built-in screen, cycle through projector options to enable monitor with: ⊞ Win + P
  7. Don't use Shut Down when finished with the computer. Instead use one of:
    • Hibernate shortcut: ⊞ Win + X followed by U then H
    • Sleep or use ⊞ Win + X followed by U then S Now you can keep the screen lid closed but turn on and use the laptop with an external monitor. To meet your last 'requirement', you can change the settings to Sleep settings so the laptop goes to sleep after a set amount of idle time:
    • ⊞ Win and then type: sleep + Enter
    • Control Panel → Screen → Power & Sleep Now you don't need to use the power button to turn it on or off.

Some other options:

  1. You could have the laptop just stay on all the time (regardless of the lid) by following only Step 1 (above).
  2. You could also schedule the laptop to startup (or shutdown) at the same time(s) every day.
  3. If you're handy with tools and electronics you could also achieve this by modifying either:
  4. You could get a docking station or USB Hub, with WOL so either:
    • an external device can wake it with a WOL Signal
    • plugging the laptop into the dock will wake the laptop if a network is present
  5. WOL is disabled by default so you'll have to enable it in BIOS.

Since I'm new here I wasn't allow to includes my list of sources and examples, so I will try to post them in a separate comment or answer.

  • 1
    How would that help me? I still would have to open the list first to start the computer, right? Changing anything there would also apply if no external monitor is attached, so "Do nothing" is not a valid option for normal, mobile operations. – janpio Oct 23 '17 at 12:26
  • @janpio it would definitely reduce steps (waiting for the external monitor before closing the lid, then pressing the mouse button to re-activate it). Also, you can get your laptop into standby any time via the start menu - it's how I do it since about forever, since I hate the lid-closing standby. And my laptop still is mobile, I can guarantee you that. – flolilo Oct 23 '17 at 12:29
  • @janpio as to steps 1-3: There's no way around it, unless you consider activating wake on lan via another machine that you will have to boot up, too, as a valid option. Somehow, you will have to start that laptop. – flolilo Oct 23 '17 at 12:32
  • Thanks @flolilolilo, 15 years of conditioning on what happens when I close the lid are impossible (and unwanted) to unlearn. I need the device to turn off and not burn through my bag or be out of juice when I use it again later because I forgot a manual "go to sleep step". I updated my question to reflect that, thanks. I was hoping there was some kind of "Turn on via USB" or similar configuration option. – janpio Oct 23 '17 at 12:55
  • 1
    ADDITIONAL LINKS TO REFERENCES [that weren't allowed above since I'm new]: ◼► *3. Switch Between Displays: (pcworld.com/article/191359/…) ◼► *4. Auto startup on schedule: howtogeek.com/204742/… ◼► *5. Improved access to power button (youtu.be/z10punCb0v0) ◼► *6. Use Laptop More Like a Desktop Machine: (instructables.com/id/…) – ashleedawg Oct 23 '17 at 15:57
4

Late answer I know - but I thought I'd give my two cents in case someone in the future comes across it.

I have 3 external monitors running off my Dell XPS 15 laptop, with the lid closed.

  1. Obviously, you'd need to "Change what happens when you close the lid" as mentioned by the other answers.

  2. Then check in your BIOS for a "Wake on AC" option. Quite simply, the computer will detect and power up when the power cable is plugged in. So in the morning, I just unplug and replug the power cable into my laptop which turns it on.

Just to be clear, you can still power off your pc with the cable plugged in. It's not like it will restart as soon as you switch it off. It will only power on in the event that the power is *plugged in again.

0

Late answer but had this same problem with my Dell all week. Got a brand new ultra wide monitor and wanted my laptop shut to work like a desktop.Seems to be an issue with a lot of people on different computer models with no clear cut answer. Crazy frustrating but here’s what finally worked for me:

This helped:

  • Boot to Bios via F2 - Goto "usb for wake settings" set to enabled
  • Device Mgr as admin, both keyboard and mouse properties have power settings with wake set to Enabled (you won't see power settings tab unless your admin)
  • Control panel under power options, choose what to do "when lid closed", laptop plugged in set to "do nothing"
  • Device Mgr as admin,HID properties, HID compliant devices power mgmt setting to enable wake Enabled
  • Device Mgr try updating drivers of both keyboard and mouse if available/out of date
  • If your wireless mouse keyboard is plugged to a USB hub (or 2nd Hub connected to 1st) with a ton of connected devices it may draw to much power which weakens the signal necessary when computer is in sleep mode. Unplug or deactivate/shut those other usb devices off. I have a Sabrenet usb3.0 from Amazon and it seems to have some power distribution issues when too many usb devices are active. I found this out by troubleshooting my USB ports. Honestly this was a major/silly find for me, but think this is what sealed the deal.

Device manager location and run as admin:

c:\windows\system32\devmgmt.msc 

Can Try if still not working but weren't necessary:

  • Control panel, Power options , go to your power plan settings, advanced settings go to usb settings select disable on both battery/plugged in
  • Control panel, Power options , go to your power plan settings advanced settings go to sleep,allow wake timers on both battery/plugged in enabled

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.