0

Since latest update i can't access remote SMB shares. Previously, i simply used \\my_ip in explorer to list them (then i eventually supply credentials and it was ok). But now, i have an error message "Windows can't access my_ip".

Prior to windows upgrade it was working flawlessly. Theses are either Windows, Linux boxes (i connect to differents VPN, but always based on OpenVPN TAP interface). The network subnet is different (local is 192.168.1/24 whereas VPN network is either 192.168.3/24 or 192.168.0/24).

  • the network attached to OpenVPN TAP interface is "undefined"
  • i disabled all firewalls and antivirus
  • i can ping the remote server
  • with WSL from Bash, i can access my shares (via smbclient -U user -L my_ip)
  • from cmd prompt, i can ping the windows name, and i can telnet my_ip on port 445 and 139 TCP, and nbtstat -A my_ip is listing computer informations
  • Anyhow, net use \\my_ip\my_share /USER:my_user is not working (error 53)
  • this is not related to VPN, i can't access my NAS local share.

What should i test now, and do you have an idea what this upgrade messed up ? Windows home edition x64 / FCU 1709. It looks like a firewall issue, but i can't figure how. The fact i can telnet SMB ports and access from WSL is questionning me.

0

It may be related to the SMB v1 vulnerability from earlier this year. They completely removed SMB v1 from Windows 10 as a safety measure. You should configure your Linux box to use a newer version of the protocol, if possible, or you must use a separate application to access the shares.

  • I'm accessing Linux with Samba 3, Samba 4, but also Windows 10 shares. In all cases the protocol in use is not specified, but i don't think W10 box would not match. I'll dig the SMBv1 issue, thank you – Graveen Oct 23 '17 at 19:24
  • It also seems lack of SMBv1 support is giving related error codes (cf link below) – Graveen Oct 23 '17 at 19:54
0

I do have a quite similar problem mapping my Toshiba FlashAirs. After upgrading to 1709 I started getting the error 53, Rollback and/or clean installation with 1703 does work without any problems.

SMB v1 is still installed after an upgrade (15 days) as noted in MSKB:

https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-windows-10-and-windows-server-version-1709

Problem persists on different machines with different FlashAirs (Rev 3 & 4).

Would like to stop playing sd card jockey.... :)

1703: https://abload.de/img/flashair_v17038fjqs.jpg

1709: abload.de/img/flashair_v1709cekje.jpg

--

edit: Didn't look much further into the issue. My problem is "solved" by using net use letter: http://ip instead for my FlashAir cards and so far it seems to work well.

  • thank you, this is valuable for me as i'm not really understanding my trouble. Glad to see i'm not alone :) – Graveen Oct 23 '17 at 19:23
  • I can't access my NAS on my local network, too. Only noticeable thing i can remember after upgrading is running BlackBird to disable telemetric. – Graveen Oct 23 '17 at 19:31
  • Reverted to 1703 is now working flawlessly, it seems we have the same trouble. – Graveen Oct 23 '17 at 23:13
  • The problems start as soon as the update is done. Tried it out on two different machines so BlackBird probably is not the culprit :D I'm just wondering how hard it is to find someone describing exactly this issue. Either there's something wrong with our machines or somehow many people haven't noticed this yet... What NAS do you have? Maybe the maker of it has some kind of support forum where other people might be reporting similar problems? – parallyze Oct 24 '17 at 11:45
  • i have deployed FCU 1709 on 4 machines: – Graveen Oct 24 '17 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.