28

I just updated Windows 10 to Fall Creators Update and since then I have 'unwanted' behavior.

If I leave open Chrome or any application when shutting down the PC, next time I boot up the system Windows will open the same Chrome tab/page and application automatically. So it looks like there is an option somewhere to remember last open task and open then on startup?

Does anyone know where to find this option or where to disable this feature?

6
  • May the windows is going into sleep mode instead of shutting down. Oct 24, 2017 at 10:59
  • Nope. 100% is shutting down.
    – TJozwicki
    Oct 24, 2017 at 11:01
  • The behavior you indicate is unwanted has been a feature of Windows 10 since it was released. It actually is working has intended.
    – Ramhound
    Oct 24, 2017 at 11:13
  • 9
    where can I disable this? I did not have this before the fall update
    – TJozwicki
    Oct 24, 2017 at 11:20
  • The thing does not even work properly. My PC restarted with many empty office apps (document not open) and empty Visual Studios (solutions not open).
    – SandRock
    Oct 22, 2020 at 7:09

2 Answers 2

15

New Answer (2020-10-22)

By now, there are dedicated settings allowing you to control this behavior.

Go to Settings > Account > Sign-in options and scroll down to the bottom. There will be two settings:

  • "Automatically save my restartable apps when I sign out and restart them after I sign in." (new in Windows 10 2004)
  • "Use my sign-in info to automatically finish setting up my device after an update or restart."

I recommend turning both off, despite only the first seemingly dealing with this feature. I still noticed some apps opening after a restart if I did not turn off both options.

enter image description here

The following, old answer workarounds this by using a script to shutdown:


Old Answer

Here's a silly workaround for the similarly silly new feature.

Some background first: Windows seems to shutdown as if %WINDIR%\system32\shutdown.exe was invoked with the /sg /hybrid /t 0 parameters. The magic is in the /sg parameter which tells it to "restart any registered applications" on the next boot. The "old" /s parameter still exists and shutdown can be invoked with it manually.

To quickly call shutdown.exe like that, create a shortcut either in your apps list (%PROGRAMDATA%\Microsoft\Windows\Start Menu\Programs for all users, %APPDATA%\Microsoft\Windows\Start Menu\Programs for the current user), or somewhere else and then pin it to start.

The important shortcut properties are the following:

  • Name: Shutdown
  • Target: %WINDIR%\system32\shutdown.exe /s /hybrid /t 0
  • Start in: %WINDIR%\system32

Optional:

  • Name: Add a non-breakable space (Alt+Num255) in front of it to appear at the top of the All Apps list. You can try other fancy Unicode characters if you like.
  • Run: Minimized to prevent the ugly command prompt from popping up shortly.
  • Icon: Change to something nice (there's an XP-style shutdown icon available in the default shell32.dll, or some close / critical icons in imageres.dll).
  • Comment: Leave a rant here about the dumb new feature.

It can look like this in the end:

The shutdown shortcut in action

If you want a shortcut doing the same for restarting, the old /r switch can be used which was replaced by the new /g switch.

5
  • 1
    It works, great! This means if I start using this new icon to shut the PC down, instead of the regular one, the Falls Creator Update will only have caused my Bluetooth dongle to stop working (for the third time)... Yay! Thank you, Microsoft, for your forced updates policy, and for changing things without giving us a choice! Nov 17, 2017 at 5:22
  • 2
    Jesus christ, this is so dumb. Microsoft have truly doubled down on the lunacy of forcing stupid "functionality" on their users, not because they asked for it but because Microsoft thinks it's the right way. Dec 2, 2017 at 14:19
  • Good but one thing goes strange for me. While holding Alt and typing 255 from numpad, I get ÿ instead of an nbsp. How?
    – iBug
    Dec 6, 2017 at 10:18
  • Different code page, try copying another whitespace character from the Wikipedia page about whitespaces.
    – Syroot
    Dec 6, 2017 at 10:57
  • 2
    Really screwed me. I work with dozens of Chrome tabs open and with Chrome set so as it opens last session. If I close Chrome I lose all my open tabs. I HATE THIS "FEATURE" (Oh and only started on my machine this morning - useless &^%$^&)
    – BeNice
    Dec 6, 2017 at 12:21
4

As mentioned in the comments, this is the intended behavior recently added to Windows. A thread on the Microsoft Windows community forum about the issue can be found here.

According to the thread there is currently no way to disable the "feature". The way to start without any apps reopening is (quote from a Microsoft Support Engineer):

If you want to start with no apps open (other than those set to auto-start via Task Manager/Start), you'll need to ensure all apps are closed before shutting down or restarting the PC.


However, according to this link, it should be possible to turn on and off.

To activate this feature, go to Settings > Accounts > Sign-in > (under Privacy) “Use my sign info to automatically finish setting up”.

You can try turning it off this option.

3
  • What baffles me is that I have "Use my sign info to automatically finish setting up" activated and I never ever encountered this feature, even though I sometimes intentionally leave my browser open when shutting down (so restoring the session is easier). What baffles me even more is that I also did not even encounter this feature when I had “Use my sign info to automatically finish setting up” deactivated. Not that I miss it*, but I still think that this is weird.
    – flolilo
    Oct 24, 2017 at 12:50
  • 4
    Toggling “Use my sign info to automatically finish setting up” does not disable this (unwanted for me) behaviour. Still looking for a way to boot without windows automatically restoring previously open applications
    – Voxel
    Nov 4, 2017 at 2:37
  • Don't think this link is relevant. It is for when Windows Update runs. Made bugger all difference to this ghastly new "feature". Just when I thought MS were getting a bit better.
    – BeNice
    Dec 6, 2017 at 12:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.