0

I have a folder/key located under

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{F0D63F85-37EC-4097-B30D-61B4A8917118}

I would like to delete it but doesnot seem I have permission to do so. Here below are what I tried already to fix the issue:

  • My account is local admin and also tried to run regedit as administrator

  • I tried to set new owner to SYSTEM but got denied.

  • I tried to set "Replace all child object permissions entries with inheritable permission entries from this object" on parent folder but got denied.

  • Since permissions window is empty for the folder/key, I tried to add SYSTEM and gave full control. But got denied when apply (screenshots are at links below)

https://pasteboard.co/GQvjFup.png

https://pasteboard.co/GQvkxW6.png

https://pasteboard.co/GQvkFsY.png

https://pasteboard.co/GQvl4wh.png

https://pasteboard.co/GQvkRNq.png

I do have a registry backup that doesnot have the folder/key. So is there a way to just replace the current registry with my backup in order to get rid of that folder/key?

  • When you attempted to chnage the owner to your current Administrator account what happen? You can revert the registry with the backup you have unless you use a System Restore point. Even then I suspect due to the key ownership not being a user on the installation in question it’s very likely attempting to restore a system restore point will simply fail. Simplest solution use the registry editor within WinRE to delete the key. – Ramhound Oct 25 '17 at 3:44
  • @Ramhound, Thanks alot and WinRE saved day!! I just changed permission within WinRE for the Registry Key. – m1xed0s Oct 25 '17 at 15:49
0

Try this at your own risk.

You can restore the registry permissions using the "tweaking all in one"

http://filehippo.com/download_tweaking-com-windows-repair/

You Will a list of all the available options, but I suggest you to select restore registry defaults.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.