23

Since the recent Fall Creators Update I'm facing a strange behavior while using Windows 10. My brother and I are using different accounts, both protected by password. When I turn on my PC and sign in, an automatic startup program (the Blizzard Launcher) warns me that it can't start since another user on the same computer is using that app. I thought that it was impossible, my brother's account can't be active if I just turned my PC on.

Actually, if I press the start button and the user icon, it says that my brother is signed in.

Image for reference

Ok, he must have turned the PC off without properly disconnecting the account, I thought, right?

So I let my brother log in his account, sign out, turn the PC off, turn it on again, log in my account. Same problem, his account is already signed in. Without even entering the password.

The same happens if he is the one to login first after booting, he sees me already signed in. If I switch account to mine, I can clearly see that my startup programs are already started and ready.

How is this possible? Windows is booting up accounts without even putting the password in?

  • The screenshot is not mine, I just took it from the web to better explain how I can tell for sure that my bro's account is already signed in – Oneiros Oct 25 '17 at 18:36
  • 1
    If you revert back to 1703 does the behavior continue to happen? – Ramhound Oct 25 '17 at 18:36
  • I wanted to be sure that this is a bug of the recent update before doing that, maybe it is some weird setting I didn't know about? – Oneiros Oct 25 '17 at 18:38
  • I was unable to reproduce the behavior on my 1709 VM. I even created two users and enabled the built-in Administrator. – Ramhound Oct 25 '17 at 19:59
  • When you "turn it off", do you have hybrid shutdown (Fast Startup) enabled? Turn that off, if so, and try a full shutdown (e.g. shutdown /s /t 0). See lifehacker.com/… – DrMoishe Pippik Oct 25 '17 at 23:47
28

Open Settings, Accounts, Sign-in Options.

Sign-in Options

Disable Use my sign-in info to automatically finish setting up my device after an update or restart

Hope that helps. Let's know.

| improve this answer | |
  • 7
    This can also be controlled by the DisableAutomaticRestartSignOn reg key in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System. If you set it to 1, the option in Control Panel will no longer be visible. – Sunil Patel Mar 19 '18 at 9:51
  • This didn't work for me. I can still boot up my PC and see that other users are logged in, even though they shut down the PC – Shiraz Mar 12 '19 at 21:47
  • This worked, although it doesn't really make sense. I was seeing the problem doing several logins, logouts, and restarts in a short period. Windows 10 isn't doing updates every minute, so why is it auto signing in users on every single restart? – pacoverflow Aug 12 '19 at 18:52
  • Typical Microsoft approach to security, just log people in without authentication. What could possibly go wrong? – Sam Watkins Aug 23 at 5:23
1

You may also need to change the settings that turn shutting off into hibernate. Windows 10 will go to hibernation instead of shutdown even if you disabled it and asked to shutdown.

The setting to disable this is reached like this:

Go to Windows 10 Configuration Panel.
Go to the System panel.
Go to Alimentation panel in the left list.
Click on Suplementary Alimentation link on the right.
Click on Choose Action of Power Button link in the left list.
Click on Modify Currently Unavailable Parameters if your not Admin.
Click on Activate Fast Boot to disable it.
| improve this answer | |
  • I think this is the screen you're referring to:imgur.com/tv1FTD9 – Shiraz Mar 12 '19 at 21:59
  • Fast boot is a different thing, unrelated to the automatic user logins. Also, there are no such items in Control Panel, did you translate the names from another language? – David Balažic Aug 25 at 8:50
  • Yes, I translated from French. – pierrebai Aug 27 at 15:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.