8

After I updated to Fall Creators Update (version 1709), my computer wakes up at around 4am every day from hibernate. I did the following:

  • Checked that maintenance disabled (and anyway time for maintenance is 11am).
  • Checked that Allow wake times is disabled.
  • Checked that allow hybrid sleep is disabled.
  • Checked tasks that can wake up the PC and there are none.  (I ran a PowerShell script that checks that there are no tasks that are allowed to wake up the computer, and then I did it manually as well.)
  • Checked that there is no device that is allowed to wake up the computer.

Also I ran these commands:

C:\WINDOWS\system32>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

C:\WINDOWS\system32>powercfg -waketimers
There are no active wake timers in the system.

C:\WINDOWS\system32>powercfg -devicequery wake_armed
NONE
  • I did reset power profile and disabled everything related to wake up.
  • I disabled all devices "Allow this device to wake up computer".
  • I disabled Wake on LAN.

When I do hibernate I can see this in the system's event log:

10/22/2017 10:02:52 PM (time when I did hibernate)
The system is entering sleep.
Sleep Reason: Application API

10/22/2017 10:02:55 PM
The system has resumed from sleep.

but I after I did hibernate, I stayed with the computer for 5 minutes and it was off. No lights, it looks completely powered off.

And next event somewhere around 4:16am:

The system time has changed to ‎xxxxx from yyyyy.
Change Reason: System time synchronized with the hardware clock.

Approximately 10 events later there is single Power-Troubleshooter event:

The system has returned from a low power state.

Sleep Time: ‎aaaaZ
Wake Time: ‎bbbbZ

Wake Source: Unknown

And I didn't do anything on the computer except upgrade Windows 10 to version 1709 (manually via Upgrade Assistant). I was running Windows 10 for about a year or so and I always used hibernate and I never had a problem with waking up (after I disabled maintenance).

Oct 28 Update Updated BIOS to latest version, made sure there is nothing in BIOS that wakes up computer. Still exactly the same issue.

But now it looks like computers wakes up not in 4am but in 6 hours and 30 minutes after I put it in hibernate. I just going to bed around 9:30pm and wake time was around 4am. Yesterday I went to bed earlier and last event in event log was at 10/27/2017 9:13:32 PM and today first event 10/28/2017 3:42:19 AM. Also I remember that one day I went to bed around 10pm and wake up time was around 4:30am Checked thru all events. Only found these new events that are relative to sleep:

PushNotifications-Platform
10/28/2017 3:42:20 AM
WNP Transport Layer received Power Management event with type Resume Low-Power on the Data Connection.

Wcmsvc
10/28/2017 3:42:24 AM
A Power change was processed. 
Reason: Operation is resuming automatically from a low-power state

Wcmsvc
10/28/2017 3:42:27 AM
A Power change was processed. 
Reason: A resume was triggered by user input

There is nothing interesting on hibernate side.

31 Oct Update Shutting down computer will keep it that way and do not wake it up.

4 Nov Update Logging off and then hibernate will keep computer in hibernate whole night. So as @Rik suggested perhaps it is application. I will try to do what he wrote: Logoff, Logon and kill all apps in startup.

7 Nov Update Updated video driver still the same problem.

  • Comments are not for extended discussion; this conversation has been moved to chat. – Journeyman Geek Nov 4 '17 at 1:01
  • @Rik so far I tried to logon kill application in startup and put it in hibernate. First attempt didn't work. I will keep stopping services and kill other tasks. Perhaps later it will work. – Vlad5Maxed Nov 5 '17 at 17:23
  • @Vlad5Maxed Yes, funny part is that here, after killing all programs, the computer did wake up after 6:28 but went to sleep again 2 minutes later. I have no task set to put my computer to sleep other than manual. If all programs are running the computer stays awake. Logging out does indeed keeps the computer asleep (as mentioned before). I was thinking about disabling all scheduled tasks but apparently that can disable login and essentially brick your OS. – Rik Nov 5 '17 at 17:49
  • @Vlad5Maxed O, wow. My computer slept through the night :) Not sure what I changed. What do you have for display-time and sleep-time. Mine was always never but I ran the power troubleshooter and that one set the sleep-time and display-time to a value other than never and now my computer sleeps through the night (I do have to end uTorrent manually because that one was set to prevent the computer from sleeping). – Rik Nov 7 '17 at 7:53
  • @Rik I did run troubleshooter and it just put computer asleep when I'm not using it. It didn't do anything for hibernate for me. – Vlad5Maxed Nov 7 '17 at 17:19
2

You should have some events in the system log ID=42 Source=Kernel Power. You can also run: Get-WinEvent -ProviderName Microsoft-Windows-Kernel-Power | Where-Object {$_.id -eq 42} | format-list The deault output is format-table which truncates the message text.

The text message for these events is different in the Eventviwer MMC that what Powershell will show:
MMC: Wake Source: S4 Doze to Hibernate
PS: Sleep Reason: Hibernate from Sleep - Fixed Timeout

If you find that message text, these events indicate that the system is transitioning from the Sleep to Hibernate. When you put the sytem to sleep, and then the max time for hibernate passes, the system will temporarily wake up to write everything to disk and go into Hibernate. Sleep is lower power fast resume, Hibernate is no power, slower resume.

Potential solutions: You may be accidentally placing the system to "sleep" when you think you are entering "hibernate". If you enter hibernate the first time, the system will not re-wake later to make that transition. If you really want to sleep (for the faster resume) and not hibernate, change the hibernate timeout to Never. You can see and/or change the current value within power plan settings by clicking Change Plan Settings then Change Advanced Power Settings

Power Options

You may also want to check for event ID 27. Note - sometimes my own system does NOT record the Event 27 when I resume from Sleep.

Get-WinEvent -ProviderName Microsoft-Windows-Kernel-Boot | Where-Object {$_.id -eq 27}
Message : The boot type was 0x2.

0x0 - Windows 10 was started after a full shutdown.
0x1 - Windows 10 was started after a hybrid shutdown. AKA Sleep
0x2 - Windows 10 was resumed from hibernation.

I see there is long line of comments now on this thread... Was that a chat you were having? Its a little hard to follow the solution from just the comments. Going to post this anyway to aide other user that may experience the same issue.

0

actually a few things could possibly be causing this: either something is awry in the update and needs to be reported/resolved by Microsoft (if so run the system file checker to make sure) or the DISM

also, multimedia settings could be causing the issue. check to make sure sleep is set under Multimedia settings in the Advanced Power Options

or this is an issue with your computers drivers not being completely compatible with creators updates. in which case use a site such as driverscape to find which drivers work.

i recommend exploring the first two options thoroughly unless you are very comfortable with drivers and the windows system as missteps can be costly.

  • This happened next night after I updated windows (about 10 hours after update). So if system file checked finds something it means Microsoft cannot update Windows properly and then we have much more problems than sleep. Also I checked Multimedia settings and didn't find anything related to this. As for driver I answered already but it is gone now. I have no idea which drive woke up and blindly updating all drivers can create instability and I don't want it. – Vlad5Maxed Nov 4 '17 at 18:08

protected by Community Nov 4 '17 at 6:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.