0

Trying to install drivers for HP LaserJet Pro M252dw. After initial setup, where everything went OK, and printing test page successfully, I'm unable to print test page again, or print from applications.

I think the issue started when I tried printing after installing driver and got popup to verify that my toner is genuine and refused to do so. I reinstalled the driver but I don't get the same verification prompt anymore. My toner is original HP toner that comes with the printer.

Then I tried HP Print and Scan Doctor, and it printed test page with no problems.

Then I figured out that the thing prints perfectly when I go to Devices and Printers / right click on HP Color LaserJet Pro M252 PCL 6 / Printer Properties / Advanced and choose Driver: HP Color LaserJet 2800 Series PS, which seems to be some sort of default Windows driver. Unfortunately, this driver doesn't recognize that printer can print in duplex, which doesn't work for me.

When I switch driver back to HP Color LaserJet Pro M252 PCL 6, one thing that I find curious is that under Printer Properties / General tab I see that paper available is Letter. The correct paper size should be A4, and it is under 2800 series driver which works.

I've tried changing paper size in all ways I could (in HP driver settings, on printer itself, through web interface) but it still says Letter in General tab. Could this be a culprit?

P.S. Printer is connected through USB.

EDIT: In the meantime, I uninstalled everything related to HP, including other HP network printer. Then I reinstalled driver from stratch - only driver, no other mumbo-jumbo like HP assistant and stuff. Now paper size is showing correct A4 size. The initial test page during driver installation printed fine. Printing from Devices and Printers or anywhere else in Windows still fails.

0

I contacted HP support and got an answer. The issue is with permissions on temp folder - it was not shared to "Everyone".

  1. Open Devices and Printers and choose Security tab.
  2. If Everyone is not on the list, click Add and enter the object name Everyone and click Check Names and then OK.
  3. Check Allow for all permissions and click OK.

Do the same for Windows temp folder (C:\Users\User Name\AppData\Local\Temp and C:\Windows\Temp by default) through Windows Explorer (right-click the folder, open Properties and choose Security tab).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.