0

I have an Acer laptop with Windows 8.1 pre-installed. In BIOS there is choice "Windows boot manager" along with "usb" and "hdd" in boot device list.

I installed Fedora with GRUB2. Before that I lowered the priority of "Windows boot manager", so that booting from "usb" and "hdd" tried first.

Through the first reboot GRUB2 launched and I chose my Fedora from the list. But any time later there was Windows starting directly with laptop launch, without GRUB2.

I found an advice in internet: to write in windows cmd (admin mode)

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

And it worked for hybernation and shutdown in both Windows and Fedora. GRUB2 now shows up and I choose OS.

BUT

It doesn't work for reboot in either of systems. When I choose reboot, the Windows starts directly. Even from Fedora. And it buggers me.

GRUB2 doesn't launch on reboot, any ideas to change it?

  • Seems like I made a mess... {bootmgr} was Windows boot manager, with all its parameters, like "default object", "resume object" etc... I saw that when I opened Visual BCD. The only parameter I changed was "path", and I guess it is no good way at all. I guess it is better to change it back and then find another, proper way to change {bootmgr} to GRUB2 or something similar – E. Kochkurov Mar 11 '18 at 9:10
0

Finally resolved with "Select an UEFI file as trusted for executing" in UEFI settings:

  1. Boot to UEFI by any way
  2. In "security" tab set supervisor password (111 is fine) to get access to advanced options
  3. Choose "Select an UEFI file as trusted for executing", then browse all the way to your grub2 file (in my case it's EFI\fedora\grubx64.efi), optionally you can give new entry a name
  4. In "boot" tab a new entry should appear, something like "EFI File Boot 0: name. Move it to the top
  5. (optionally) remove supervisor password - enter old and type nothing for new. advanced options will block again.
  6. Save and exit.

Now I have Grub2 always appearing, even after reboot. Also, I heard that new Acer computers don't have "Select an UEFI file..." option anymore. I'm lucky

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.