I am attempting to run an event via Task Scheduler in order to restart my trackpad driver (code to do so below) every time my system wakes up, as a troubleshooting measure. However, in Task Scheduler, I am having some issues.

If I run the program manually via Task Scheduler it works perfectly and shows up in the event's history. However, giving it the change to try and execute itself after the "Power-Troubleshooter" event is triggered - it just doesn't work. And I need to find out why.

There is no history in the Task Scheduler that shows the event was ever performed, it's just blank. However, I can see in Event Viewer the event 'Power-Troubleshooter' was called. Below are all my configurations:

Task Scheduler - General
Task Scheduler - Triggers
Task Scheduler - Action
Task Scheduler - Settings

And finally, the actual event that is being triggered in Event Viewer:

Event Viewer - Event

It's important to note this only works when I run as administrator, for some reason it just does not like it when I select my profile to run the Task on.

Any pointers as to getting this working would be appriciated.

  • Have you enabled the administrator account? I use WinAero: the down-load link is hard to find, but the software is good. Alternatively, this link shows how to do it manually. – AFH Oct 28 '17 at 9:26
  • Yeo! Admin account is active. – Polymer Oct 28 '17 at 9:37

Found the answer here! Turns on, there are actually two listed event 'Source's with BOTH names being "Power-Troubleshooter". Annoying, however, switching to the second one yielded perfect results!

So if anybody else is having this issue, give that a try!

| improve this answer | |
  • I can see only one event source called "Power-Troubleshooter" under System. Where is the other? – user419144 May 22 '19 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.