0

We have 1 stationary PC, 1 router and 3 devices. Devices connected via WiFi to router, but PC connected via cable. And in a computer game launched from PC it can't see local WiFi net.

So - is it possible to turn cable connection into wireless (like emulate it somehow)?

PC has WinXP*32 and Win7*64 OSes.

UPD: My router's model is TL-WR841HP.

  • You can get a Wi-Fi USB adapter. – BillDOe Oct 29 '17 at 22:52
  • Well i can't believe that it couldn't be done by soft-way. I mean i have physical connection with router, it definitely should be possible to make soft believe that it's WiFi cuz it's just same damn router. – Markus_13 Oct 29 '17 at 23:05
  • Yes, I agree. I had the same problem, and I never found any other solution. And another problem is switching to the Wi-Fi connection when you want to use it, as Windows (assuming that's your OS) will always choose the network connection with the best quality. – BillDOe Oct 29 '17 at 23:07
0

Your wifi router is your concern here. There isn't any way to emulate wifi on your PC without actually connecting it to your wifi network (unplugging the Ethernet cable). Now, it is possible that your internet router could allow this sort of emulation as you call it (really network configuration), but you would have to look at your router settings and the capability would vary based on your exact router.

  • Added UPD to question with my router's model. What exact settings should i be looking for? I'm kinda noob in wifi/ethernet and such. All im familiar with is TCP/IP, UDP and HTTP lol)) – Markus_13 Oct 30 '17 at 4:27
0

Its not possible to "emulate it", however you should be able to modify your router such that the WIFI and Ethernet are bridged onto the same network and can see each other. (Maybe you have some kind of "Guest WIFI" or "Isolate WIFI" network setting on your router.

(Are you sure that there is not more then 1 WIFI network available from your router? Quite often WIFI routers have "guest" SSID which isolate them from the rest of your network, as well as a regular SSID which is bridged to your LAN. If you are connecting to the guest SSID when both are offered, just connect the WIFI devices to the regular SSID)

  • I have only one SSID + options such as: SSID Broadcast, WDS Bridging, AP Isolation and few others in "Wireless" section at least. – Markus_13 Oct 30 '17 at 4:30
  • Is AP Isolation turned on? If it is, turn it off, that could be causing the issue. – davidgo Oct 30 '17 at 5:16
  • Checked both states of that option. Still didn't worked, but the weird thing is that it works somehow with Android device emulator even when it runs on stationary PC. – Markus_13 Nov 1 '17 at 1:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.