4

I have a build intended for mining. I'm using Ubuntu 16.04.3 LTS. My specs are as follows:

MoBo: ASUS TUF Z270 Mark 1 LGA1151

CPU: Intel Pentium G4600 3.6 LGA 1151 GHz Dual-Core

RAM: (2x) Patriot Memory Viper Elite Series DDR4 4GB 2400MHz

PSU: Corsair HXi Series, HX1200i, 1200 Watt

GPU(s): (5x) XFX AMD Radeon RX 580

The system works beautifully if there are <= 3 GPUs connected via PCIe VER 007 16x to 1x powered risers.

If I connect one or more additional GPUs, I get a single beep code, and a warning that peripherals such as my keyboard cannot be located, followed by a black screen.

Having done a bit of reading, there were some suggestions to turn off secure boot. I did that, to no avail.

Does anyone in the community have some suggestions?

migrated from askubuntu.com Oct 30 '17 at 13:41

This question came from our site for Ubuntu users and developers.

7

You must enable the 4g decoding option on your motherboard BIOS options to boot the system with more than 4 GPUs on board. The option allows the system to enable or disable memory mapped I/O for a 64-bit PCIe device to 4GB or greater address space, because the primary VGA card should always be mapped below 4GB address.

You have also to update the BIOS, if the 4g decoding option is not available on your motherboard BIOS. If you need help on how to update BIOS, you can check the wiki BIOSUpdate. After that, in some cases, also disable the integrated graphics (if present) can help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.