4

VLC Media Player adds a song to it's default playlist when you double-click that file in Explorer. If I'm jumping around quickly, that playlist becomes large and unwanted.

Is there a way I can configure VLC to not keep a playlist open and just play songs one by one when they're double-clicked?

4

I don't know which version of VLC you are using, but, from a long time, VLC supports the feature that you are asking for. Here I am providing the steps for VLC version 2.2.6.

Basically there are three options in VLC settings that you need to look:

Under the interface tab of VLC settings, you will find an area called "Playlist and Instances" (as shown in this image). Ensure the following tick boxes are as mentioned.

  1. Tick box corresponding to "Allow only one instance" should be ticked on.

  2. Tick box corresponding to "Use only one instance when started from file manager" should be ticked on.

  3. Tick box corresponding to "Enqueue items into playlist in one instance mode" should be ticked off.

Other than this, if you prefer to turn off the playlist every time VLC is opened, open VLC, go to View, and click Playlist. This will turn playlist off. Now close VLC in order to save the setting.

8
  • This looked promising but did not solve the problem for me.
    – Ryan
    Aug 6 '18 at 2:18
  • Why? What's happening?
    – Ombrophile
    Aug 7 '18 at 4:51
  • 1
    I still have the problem that the original asker had. Every time I double-click a file in Windows Explorer, it adds to the VLC playlist instead of clearing the playlist and playing just that file. Windows Explorer already has a right-click context menu option of "Add to VLC media player's Playlist", and I sometimes enjoy using that, but I want the main (left-click) opening action to just play that one file (i.e. clearing the playlist).
    – Ryan
    Aug 7 '18 at 15:43
  • 1
    I am guessing you are using windows. I would suggest you look into explorer context menu entry of VLC in windows registry, i.e., regedit.exe. A simpler way to explore that is to use the autoruns sysinternals utility -> docs.microsoft.com/en-us/sysinternals/downloads/autoruns (check the explorer tab and see if the entry is correct or whether that entry is causing files to be queued to VLC instead).
    – Ombrophile
    Aug 7 '18 at 16:49
  • Yeah, don't see it. Two or three years later, or just because I'm on a Mac.
    – Jacob Lee
    Feb 2 at 18:22
1

See this post.

In summary:

Tools => Preferences => Show Settings (All) => Interface => Main Interfaces => Qt => Save the recently played items in the menu (UNselect)

Screenshot:

1
  • This looked promising but did not solve the problem for me.
    – Ryan
    Aug 6 '18 at 2:18
0

hidden border

There is a hidden cover art border at the top that you can pull down This opens the a menu with the total playlist time at the top screenshots

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.