I'm trying to get the Astrill VPN 32-bit v3.2 application working on Ubuntu xenial 16.04.3.

On trying to login, I get a message saying "Could not load SSL library".

Astrill support's only suggestion is to uninstall, reboot and reinstall the application, which has not helped.

I've also tried installing the i386 version of openssl, which hasn't helped either.

What else could I look at to try and resolve this?

2 Answers 2


First make sure you have openssl installed. You will need version 1.0 since Astrill does not support 1.1. To install 1.0.2, run

sudo apt install openssl=1.0.2g-1ubuntu4.8

Then install shared libraries, first check which version you want by running apt-cache search libssl | grep SSL. Example output:

libssl-dev - SSL development libraries, header files and documentation
libssl-doc - SSL development documentation documentation
libssl1.0.0 - SSL shared libraries  <-- version number

Install the library with the correct version:

sudo apt-get install libssl1.0.0

From the conversation in the comments, you also need to install libssl-dev, again, make sure the version is 1.0.

sudo apt install libssl-dev=1.0.2g-1ubuntu4.8

It is possible you need to install the packet ca-certificates as well.

If the above did not solve the problem, open the file /etc/ld.so.conf as sudo and add a new line at the end


Dependin on yuor system, the path could be different. Two other locations to try are /usr/local/lib and /usr/lib/openssl-1.0, see here and here.

Then run sudo ldconfig.

  • Thanks, I tried all the above including the alteration to /etc/ld.so.conf without success. Could this be an issue with Python 2 vs Python 3? I notice that I have openssl in both python2.7 and python3.5
    – MHG
    Oct 31, 2017 at 7:46
  • @xiuyuan What version of openssl are you using? I saw here that you need openssl-1.0. Astrill can't use 1.1. For the python issue, I haven't seen anything about it. I guess if you have both installed it should be fine. You can also try this path: usr/lib/x86_64-linux-gnu/openssl-1.0.0.
    – Shaido
    Oct 31, 2017 at 7:52
  • I was on openssl 1.1. I tried downgrading to 1.0 with sudo apt install openssl=1.0.2g-1ubuntu4.6 and confirmed with openssl version, but still have the same error from Astrill.
    – MHG
    Oct 31, 2017 at 8:12
  • @xiuyuan Did you try adding usr/lib/x86_64-linux-gnu/openssl-1.0.0 to /etc/ld.so.config and run sudo ldconfig afterwards? If that path doesn't work, try with usr/lib/x86_64-linux-gnu/. Also, you can try checking the shard libraries (in hte answer above) after the downgrade of openssl.
    – Shaido
    Oct 31, 2017 at 8:14
  • 1
    Success! It seems I also needed sudo apt install libssl-dev=1.0.2g-1ubuntu4.8. Now it works. Thanks a lot for your help.
    – MHG
    Oct 31, 2017 at 8:49

Following Hugh's comment on Shaido's answer, simply installing libssl-dev solved the problem.

sudo apt-get install libssl-dev

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .