0

I have Cat6a S/FTP Shielded cable, TP-Link TL-SG1024 (24 port) switch, deleyCON Cat6a wall sockets (with 2 RJ45 ports) and a Cat6a deleyCON (24 port) switch panel. I bought Cat6a RJ45 connector (FTP Shielded 8p 8c 3u-50u) but the connector doesn't seem to plug into any of my equipment (patch panel, switch or wall sockets). Can someone advice on why that is the case? and how I can resolve the issue? or do I have to buy a different type of connector?

I can provide pics or anyother information if required. Just to explain, when I try to connect the connector to any of the equipment, there seems to be a ridge at the top of the connector that is stopping it going into the slots

Any help would be much appreciated. TIA

  • What is a connector (vs a cable)? Does your cable not have a male connector on it? – derz00 Oct 31 '17 at 11:57
  • By connector I mean the actual RJ45 connector. My cable doesn't have the RJ45 connector at the end (mainly because I bought the cable in bulk to lay down wired network at home). I have RJ45 connectors that I will connect to the end of the cable. Hope this helps – Zac Oct 31 '17 at 12:02
  • As far as I know there is only one standard for RJ 45 connectors. I don't know what would be wrong... – derz00 Oct 31 '17 at 12:38
  • That's exactly what I thought but apparently that's not the case – Zac Oct 31 '17 at 12:50
  • Can you provide a photo of the business end of the connector as well as any details on the packaging? – derz00 Oct 31 '17 at 13:56
0

This was my fault. I hadn't crimped the connector. Once I crimped it, it now fits fine. However, the connectors come with a funny load bar where both ends are the same so it looks like i'll have to stager it manually.. unless I can get load bars with hollow end. Sorry guys

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.