0

I can't seem to figure this one out. Running on CentOS 7, I'm trying to get a CIFS mount working using my FStab file.

//<ip>/downloads /mnt/downloads cifs user,gid=100,forcegid,rw,auto,username=guest,password=guest,domain=<domain>.local 0 0

2 users:

  • user1
  • user2

are both in group 100 (users) primarily!

Mounting the share using:

mount /mnt/downloads

works perfectly but I'm unable to write data into files. I seem to be able to create files but adding data to them is not possible. I'm getting a permissions denied from the system.

[user1@host mnt]$ ls -hl
total 0
drwxrwxrwx. 3 root users 0 Oct 31 13:51 downloads
[user1@host mnt]$ cd downloads
[user1@host downloads]$ touch test1
touch: cannot touch ‘test1’: Permission denied
[user1@host downloads]$ echo bla > test1
-bash: test1: Permission denied
[user1@host downloads]$ ls -hl
total 0
-rw-rw-r--. 1 1025 users 0 Oct 31 13:37 test1

User 1025 seems to be the user from the NAS system (aka user guest).

Can you point out what I'm doing wrong?

  • See who the owner of the existing file is as I thought with Linux only the owner of the file can modify it regardless of the folder level permissions so just an idea for something to check I suppose. Linux rookie here though so just an idea only. So maybe that file already exists and that's the issue so try creating another file named something differently and see what happens. – Pimp Juice IT Oct 31 '17 at 14:47
0

It was the --ghost parameter within auto.masters that was missing and was absolutely needed to get things running...

  • Could you describe how to use this parameter and what it does?  Please do not respond in comments; edit your answer to make it clearer and more complete. – Scott Nov 9 '17 at 0:28

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.