1

Question posed by IT repair tech. Client's netbook. Acer Aspire E11 (ES1-111M-C3CP) Celeron N2840, 2GB HD, 32GB eMMC soldered on to board (non-removable).

Corrupt Windows won't boot, suspect Win10 or 8.1 64bit. Successfully booted to Xubuntu 17.10 by pendrive, backed up data to other pendrive (thankfully).

Since then, have not been able to adjust any settings in UEFI, except date and time.

Also ignores all attempts to boot from other device. Cannot take off UEFI mode to Legacy. Won't boot off UEFI external devs (Win10 home 1709 pendrive 64bit created by MS media creation tool, Win10 DVD via USB DVD drive). Won't boot off legacy either (uNetBootIn created Xubuntu 17.10). Also won't allow me to change non-boot options such as touchpad mode (basic / advanced). When F10 pressed to save and exit, changes don't persist after immedaite reboot. Consistently trying to boot off corrupted Windows.

Have tried removing and reseating CMOS battery. Don't think the CMOS battery is flat, the date and time stay correct all the while.

Seems similar to this guy, what we have in common is the symptoms and that it was 17.10 ubuntu of some flavour (though he's installed Ubuntu 17.10, I ran Xubuntu off pendrive). https://askubuntu.com/questions/970451/unable-to-save-bios-options-after-ubuntu-17-10-upgrade

Something in latest Ubuntu crippling EFI settings, blocking future changes? If I'm correct, I have no idea how to resolve, especially as storage soldered on to board, cannot be read in any other computer. Suggestions?

0

Yes there is an issue with Ubuntu 17.10 and all flavor of 17.10

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1734147

I have it too!

If you can boot Linux you might be able to fix it by upgrading.

However, I'm stuck because I'm on windows. I had a Live CD that corrupted the bios.

0

In addition to the suggestions made on the official bug webpage (linked by Aubrey) consider the following that I've found out since (like, last week):

If the laptop / computer supports flashing UEFI from within UEFI, you can possibly download and install it to fix - this recovered a laptop at our repair shop, an Asus X555C. I re-flashed the laptop from within UEFI and now all settings restored. The UEFI firmware downloaded fromn the site was same as version already installed on the laptop, but it worked.

1
  • This is the second time that I have submitted the above as an answer, not sure why was it not accepted as an answer before, it clearly answers the question, but maybe there was too much "waffle" if there's any dispute that this is an answer to the question, please get a message to me before deletion. – David1618 Mar 5 '18 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.