0

This is nuts, I know. But I cannot get my new Netgear switch, to pick up the time from the time server used on the LAN. I've tried both CLI and GUI, I can't work out what it needs.

The LAN has a dedicated NTP server, which is working. I've tried every combination of settings to get the switch to pick up time from it, and followed Netgear guides as well as pages found online, but it sits at "local" and doesn't sync to the time server whatever I seem to do.

I'm not sure if that is because the local time server is NTP not SNTP, but all the examples show it syncing to a normal NTP pool, so it's probably fine. Ideally I would have thought it would autodetect the NTP settings and server from LAN DHCP params when it checks DHCP, but it isn't doing that either.

When I enter the settings, I can get a long "waiting" screen, but it always shows "local" even after waiting many minutes.

The setup I have would simply need a broadcast NTP request (the NTP server just has an IP, which could vary in future; there's no DNS on this LAN subnet). Surely it's not that complicated but I just can't find what it needs to make it work.

Rather than posting things that failed, I'd like to just ask what I have to do, to make it work.

This is the current config pages:

enter image description here

UPDATE 1

After @Ramhound's comment below (which was helpful, thank you!), I have come to the conclusion that the issue could be that the setting "routing mode" is incorrect. My basis for this is that although it's on the correct subnet/broadcast domain NTP broadcasts just aren't reaching the NTP server, and "ping" on the switch to the NTP server isn't getting a reply either.

(However it managed to send a DHCP request and reply without issue to the exact same server, no problem there? The switch and NTP/DHCP server are also definitely on the same subnet - I just rechecked - so broadcast should work?)

I think that might imply it doesn't know how to send packets to the server for NTP/PING purposes and so it isn't trying to send them (or is sending on the wrong ports), probably that would be a routing issue? But if so, why did DHCP work but NTP/PING not? I don't know. There's probably a good reason. I don't understand the "routing mode" setting enough to know if it should be enabled or disabled. Right now it's disabled, the switch default.

  • "I'm not sure if that is because the local time server is NTP not SNTP" - You need to determine that before we can help. Out of interest what is the checkbox? – Ramhound Oct 31 '17 at 20:46
  • 1
    "When I enter the settings, I can get a long "waiting" screen" - This is an indication that the router is attempting to contact the SNTP server but isn't able to. – Ramhound Oct 31 '17 at 21:01
  • All sources including Netgear say "yes" - SNTP can sync to NTP servers. Checkbox is a usual kind of "select one or more rows to perform an action on" (eg "delete these entries") and the top checkbox is "all/none". Packet capture on the NTP server shows other devices receive/reply on port 123, but none from this device, so you're probably right about the issue. But the switch is set to broadcast for time sync, the switch's has the right subnet, nothing in the way, and broadcast shouldn't need anything more. So why aren't requests from the switch being received? – Stilez Oct 31 '17 at 21:20
  • @Ramhound - updated based on your very helpful comment. I think you're on the right track. More info added to the OP. – Stilez Oct 31 '17 at 21:37
0

Following @Ramhound's very useful comment to the OP, I was able to find the solution.

There were two issues. First, the switch needs to be set from "switching mode" to "routing mode". It auto-reboots. After restarting, this immediately let PING (from the "troubleshooting" menu) work. That suggested that time sync would also begin to work.

The other issue is the GUI. I had to click a couple of times to get a screen which showed that the setting was clearly being set (Netgear's web GUI has a couple of minor issues in that area). But it still didn't seem to have done anything, because nothing changes until the next poll (anything up to 10 mins later, or 6 mins later by default). But as I browsed the system pages and SNTP config info, I suddenly noticed after a few minutes it was showing "success" and the correct date/time. I had to use unicast to get it to work. It might have worked with broadcast but I didn't retest with broadcast, I was just glad something worked!

So clearly it's 4 things:

  • Enable "routing mode" not "switching mode".
  • Set up SNTP and add some data properly. Try unicast and ensure there's an entry for at least one NTP server if needed. An ordinary NTP server will do, it doesn't have to be an SNTP server, and can be an IP not a domain.
  • Go to the SNTP config and switch from "local" to "SNTP" and choose "unicast" or "broadcast" (start with unicast and a fixed IP/host, might be easier). Repeat doing it until the GUI looks like it's doing some serious config setting.
  • Wait and occasionally watch the status pages to see if it shows "success" or the correct time.
  • If not, ping the NTP server or other LAN devices in the same subnet, and do some packet capture, to check packets are actually getting to the NTP server, and suspect the routing if either of these don't work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.