1

According to How to Change Content Process Limit in Firefox Browser the default for the content process limit since FF 55 is 4 and this is also mentioned on Firefox's performance settings page.

Well, I'm running 56.0.2 (64-Bit) here and the value is set to 1 and I can't change it (the drop-down box is grayed out).

Starting FF in safe-mode does neither change the value nor activate the drop-down box.

There are three dom.ipc.processCount[...] settings in about:config set to 1. Q1: Is this the place to change the setting if it is not changeable via the UI?

Q2: Why is it not changeable via the UI? Q3: How to fix this?

3
  • Go to about:support and there'll be a line that tells you why multiprocess is disabled. Usually either incompatible addon or recent use of accessibility APIs. – Bob Nov 1 '17 at 22:37
  • @Bob Without the newly created setting described in my answer about:support told me Multiprocess Windows: 0/2 (deactivated by Add-on). Now it says 2/2 (activated by user) but the line Web content processes wasn't available at all before – despite the number of processes having been 1. – Gerold Broser Nov 1 '17 at 23:22
  • If you really feel like changing it and it doesn't work with normal Firefox, then you might want to get Firefox Beta or Nightly – John Lou Nov 2 '17 at 1:43
2

There are reasons Firefox disables this dropdown on purpose. (In my opinion this is bad UX because it will only confuse the average end user). Most obvious would be incompatible addons. However since you tested in safe mode addons should be disabled, but maybe they have set safe mode to only allow one process since its a newer feature.

You can check about:config to verify browser.tabs.remote.autostart is enabled. In my case I did this manually and had Electrolisys/Content Processes working in version 54 but it seems someone cocked something up with the 56 release, to my suprise it was locked to 1 as you are describing. This was just using the normal Release channel updates. I can only enable it now by setting browser.tabs.remote.force-enable which is not advised. Then you can use the UI to select the number of processes. (So I changed it back after seeing that force-enable worked).

3
  • browser.tabs.remote.autostart = false here. If I set browser.tabs.remote.force-enable = false now the drop-down box still contains 7 but but it's deactivated and there's again just on firefox.exe process. I guess this is not only confusing the average end user. – Gerold Broser Nov 1 '17 at 23:04
  • Uhm yes I agree. I was just saying that it worked in the past without using the force method. Did I mix anything up in my anwser? – Jabokoe Nov 1 '17 at 23:10
  • I do not see anything you mixed up. I did, on the other hand, in my previous comment: 2 consecutive "but"s and one missing "e". :) – Gerold Broser Nov 1 '17 at 23:28
2

Answer to Q1:

Changing the setting dom.ipc.processCount in about:config changes the value in the UI's drop-down box accordingly. I set it to 7.

But this is just the first part of the story:

  • There was no line Application BasicsWeb content processes in about:support after that.
  • I had to create a new Boolean setting in about:config (according to a hint from dom.ipc.processCount; a C&P backup of your FF profile folder before is recommended there):

    browser.tabs.remote.force-enable = true

  • After a restart there's a line Web content processes: 8/7 in about:support and there are 10 firefox.exe processes displayed in the Task Manager.

8/7 and 10 still gives me riddles but my i7-6700 (4/8 cores/threads) is still smiling with this 9 more processes and FF behaves much more responsive now.

Just two questions to go.

UPDATE

See also the answers to How to check if multiprocess e10s option is enabled in your Firefox.

According to dma_k's comment to this answer there the following finally works here:

  • browser.tabs.remote.autostart = true
  • browser.tabs.remote.autostart.2 = true (didn't touch that)
  • browser.tabs.remote.force-enable = false (the newly created above)
  • extensions.e10sBlockedByAddons = false (mentioned in dma_k's comment)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.