I recently installed Office 2016.

In my start menu I can see the Office 2016 shortcuts, such as Excel 2016:

Excel 2016 in start menu

However, when I type "Excel" in the Windows Search bar, I still only see "Excel 2013", and not "Excel 2016". This is despite the fact that Excel 2013 no longer exists on my machine (clicking on the "Excel 2013" shortcut, does literally nothing).

Excel 2013 still showing up in search

As you can also see from this picture, I have tried rebuilding my search index, as well as every other action you can possibly take within the indexing options of Windows including;

  1. Deleting all indexed locations.
  2. Delete and Rebuild the index.
  3. Re-adding default indexed locations.
  4. Again rebuilding the index.
  5. Changing the index location.
  6. Restarting
  7. Restarting the Windows Search service.
  8. Multiple combinations of the above steps.
  9. Every solution mentioned here and here.
  10. Changing my user to an administrator (before only a standard user) and doing all of these steps again.
  11. Cleared my 'device history' in search settings.

No matter what I have tried, search always returns Excel 2013, and does not find Excel 2016.

My primary question is how do I make search not show "Excel 2013"? As a bonus, how do I get it to instead find "Excel 2016"?

To be clear this has little to do with Office, its simply symptomatic of a larger issue I have with Windows Search in general (other programs exhibit the same behavior, and programs that should appear are not appearing in search).


In case it helps, I am running Windows 10 Enterprise, Version 1607, OS Build 14393.1770

  • 2
    See if the fix here helps Windows 10 Creator's Update: Search Not Finding Apps - Microsoft Community turn on the Background Apps "Let apps run in the background" master switch (found in Settings -> Privacy -> Background Apps). – Win32Guy Nov 2 '17 at 11:02
  • thakns for the comment. Unfortuantely, under the "Let Apps run in the background" I only see a list of apps and toggles for those specific apps. There is no general "Let Apps Run in the background" toggle switch. It may be because my computer is group managed – n00b Nov 2 '17 at 12:04
  • Ok. In older builds the master switch "Let Apps run in the background" will not be there. – Win32Guy Nov 2 '17 at 12:19
  • edited post to include windows version incase that helps – n00b Nov 2 '17 at 12:24
  • Also Settings -> Privacy -> General -> "Show me suggested content in the Settings app" must be turned on, for some reason. This solved issue with search for me (+ what @Win32Guy suggested) – mikiqex Apr 17 at 14:13
up vote 1 down vote accepted

I was able to resolve my issue by enabling "Let apps run in the background." If you don't see the option in the Windows UI, you can still enable it via the registry. To do so;

  1. Press windows logo key + R to open the run dialog. Type "regedit" then press enter.
  2. Navigate to the following key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\BackgroundAccessApplications
  3. Right click on BackgroundAccessApplications, and select New -> DWORD (32-bit) Value. Name it GlobalUserDisabled and set its value to 0.
  4. Restart.

An additional step I performed in between 3 and 4 were to navigate to the key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\BackgroundAccessApplications\Microsoft.Windows.Cortana_... and set both the "disabled" and "disabledByUser" values to 0. I'm not sure that made a difference, but I'm including that as well, in case steps 1-4 do not do it for you.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.