0

Introduction

What I am trying to do is mirror my Windows 10 screen to my TV in another room. I have Kodi installed on a raspberry pi that is connected to this TV. Kodi supports apple airplay. I have successfully played videos over apple airplay using PlayOn software from my computer so I know the apple airplay part works with at least one piece of software. PlayOn doesn't support mirroring the entire screen though and only does video windows.

Problem

I have tried a few different programs, including AirParrot 2 which appear like they should work across a plethora of devices. Every time they search on my network for supported devices, they do find my raspberry pi listed as "Kodi". However, whenever I actually connect they always fail. In AirParrot's case, the connecting icon just spins for hours with no connection happening.

I am of course open to other programs but my question is not focused on that aspect. It seems that the different programs I have tried never can connect so there must be something I am consistently doing wrong.. perhaps something not setup correctly on Kodi? I thought just enabling ZeroConfig and Airplay was all that is needed.

FYI my version of Kodi is Isengard (15.1) and I have Windows 10 on my computer I am trying to broadcast. The raspberry pi is connected to my network via ethernet cable, as my computer is as well.

  • Your Kodi version is ancient but that's not the issue. Kodi by default does not accept such connections, it must be enabled in settings (and enabling AirPlay isn't enough). Unfortunately I can't be of much help with that because the current version I'm using is totally different. In 17.5 you'd click the cog wheel then "Service Settings" > "Control" and enable "allow control from applications on other systems" – user772515 Nov 3 '17 at 5:11
  • BTW, your title is quite misleading. Later you say they do find my raspberry pi listed as "Kodi" so... Kodi is found after all. The problem is it refuses the connection as it does by default. – user772515 Nov 3 '17 at 5:14
  • @MichaelBay I guess I haven't been looking for quite some time for updates. Perhaps you are on to something though. I will try to update my Kodi to a later version. Thanks! – Eric F Nov 3 '17 at 12:32
  • @MichaelBay So I updated my Kodi to the latest version and the same problem. I am at Krypton 17.5 now. I have "allow control from applications on other systems" turned on too. – Eric F Nov 6 '17 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.